WordPress.org

Support

Support » Plugins and Hacks » WoW Armory Character » [Plugin: WoW Armory Character] No Pictures or the Progressbar is shown

[Plugin: WoW Armory Character] No Pictures or the Progressbar is shown

  • I’m running the plugin on a WordPress MU installation.

    Main URL -> http://www.dark-sphere.de

    and the problem occours in the MU Installation of nulli

    URL -> http://www.dark-sphere.de/nulli/

    The Directory permissions in the Plugin / cache Folder are (7)777 ( writeable from all Users ) but the Pictures are still not Created with an error thrown ( instead of the URL to the Picture ):

    <img src="
    <b>Warning</b>:  fopen(//cache/spell_holy_guardianspirit.jpg) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory in <b>/var/www/vhosts/dark-sphere.de/httpdocs/wp-content/plugins/wow-armory-character/class-wow-armory-character-view.php</b> on line <b>248</b>
    http://eu.media.blizzard.com/wow/icons/18/spell_holy_guardianspirit.jpg" alt="Heilig talent spec icon" />

    plz check if you can fix this behaviour 😉

    Server Runs with Apache 2.2.9 / PHP 5.2.6

    http://wordpress.org/extend/plugins/wow-armory-character/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Seems like the Problem is a wrong Checkup from WP MU Plugin Directory

    Since the Plugin works fine under / dir
    but not under Created MU Sites /nulli in this case, i checked some of the Code, after replacing the plugin_dir_path($wacpath) with the Hardcoded path to the plugin Dir, it Created files in the Cache dir directly but it did not pull the pictures from there any further.

    instead of pulling the pictures out of /wp-content/plugins/wow-armory-character/cache it tryed to pull the picture out of nulli(or which MU site is active)/wp-content/plugins/wow-armory-character/cache

    Hope this helps to fix the Problem with the addon.

    Plugin Author Adam

    @blueajcooper

    Thanks for reporting this. I’ll investigate how the plugin works with the MU version of WordPress. I’m not sure why the plugin is failing as it is since it should still discover the correct path with the code given.

    Are you using symlinks to get your folder (nulli) to appear where it does? The underlying functionality that plugin_dir_path calls has issues with resolving symlinks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WoW Armory Character] No Pictures or the Progressbar is shown’ is closed to new replies.
Skip to toolbar