WordPress.org

Support

Support » Plugins and Hacks » qTranslate » Plugin works under 3.5

Plugin works under 3.5

  • I just updated my wordpress blog and now the editor tells me, that the plugin is incompatible. But when I reactivate the editor everything is still there and works.

    How can I get rid of this error message? I know, probably there will be an update soon. But my customer wants to launch the new website today.

    Anybody any suggestions?

    http://wordpress.org/extend/plugins/qtranslate/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Ok, I just went into the plugin’s PHP-file and changed

    define('QT_SUPPORTED_WP_VERSION', '3.4.2');

    to

    define('QT_SUPPORTED_WP_VERSION', '3.5');

    this works, but is not a very good solution.

    Bei dir hat das Plugin funktioniert ?

    Bei mir zerschiesst es den Editor total. Ich bekomme folgende Nachricht angezeigt

    “The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.”

    Wenn ich dann auf “reenable” klicke – zerlegt sich der Editor. Dann habe ich vllt ein 10px hohes fenster um den text zu bearbeiten

    Ich hoffe es kommt ein Update fĂŒr das Plugin.

    Just updated to WP 3.5. too and am facing the same problem.

    I tried to edit the php file as described above, but now I am having a constant warning at the top of the page:

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/../wp-content/plugins/qtranslate/qtranslate.php:1) in /www/htdocs/../wp-content/plugins/qtranslate/qtranslate_core.php on line 71

    So yeah, I’d appreciate a quick update as well, am relying on this plugin a lot (:

    So gehts mir auch, man kann aber wie gewohnt in die Textfenster schreiben… sieht nur komplett kacke aus :/

    ich hab fast 20 sprachen die ich damit pflege und fremdautoren die darauf zugreifen 😀 da wird das ganze echt unĂŒbersichtlich – ich kann nur hoffen das schnellstmöglichst ein update kommt.

    bringt es vllt was, wordpress zu downgraden? hat das schonmal jemand gemacht ?

    Mit 3.4.2. hats definitiv noch funktioniert. Aber ich hab jetzt nicht ne Stunde Datenbanken gesichert etc pp um jetzt wieder zurĂŒckzuschrauben xD

    Also bei mir kann ich das mit dem “zu kleinen Editor-Fenster” bestĂ€tigen. Aber ich habe da glĂŒcklicherweise ein kleines Icon rechts unten, mit dem ich den Editor immer wieder vergrĂ¶ĂŸern kann.

    Das ist zwar lÀstig, aber momentan verschmerzbar.

    Even if I do all this I still have the warning on every page and for example cannot save any settings I change.

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/../wp-content/plugins/qtranslate/qtranslate.php:1) in /www/htdocs/../wp-content/plugins/qtranslate/qtranslate_core.php on line 71

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/../wp-content/plugins/qtranslate/qtranslate.php:1) in /www/htdocs/../wp-includes/pluggable.php on line 876

    Use this version, it works (community modified at the official forum). Click on download on the right side:
    https://bitbucket.org/odin88/qtranslate-wordpress-3.5

    Thank you Eigenstil

    This simple fix worked for me too on 3.5.1

    define(‘QT_SUPPORTED_WP_VERSION’, ‘3.4.2’);

    to

    define(‘QT_SUPPORTED_WP_VERSION’, ‘3.5.1’);

    It looks like the developer can no longer support it which is a shame as it is the best out there. Maybe someone can suggest a replacement.

    It looks like the developer can no longer support it

    Do you have any official information about this?

    The developer updated the latest version, it works with 3.5.1 now! Just look in the forum!

    do you mean this thread: http://www.qianqin.de/qtranslate/forum/viewtopic.php?f=3&t=3872

    could you point us to the direct download-link or the post with the link in it? that would be great 🙂

    Yes, that’s the thread but I just mentioned it for information. Since yesterday, the latest qTranslate version works perfectly with the latest WP. You don’t need to do anything, just auto-update qTranslate.

    Or in versions: WP 3.5.1 + qT 2.5.34 = OK

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Plugin works under 3.5’ is closed to new replies.
Skip to toolbar