Support » How-To and Troubleshooting » [Plugin: wordTube] Can’t Upload Media Files

[Plugin: wordTube] Can’t Upload Media Files

  • I know this topic already in this forum, but marked as ‘resolved’ without any solution.
    I’m having the same problem, i get an error when upload.

    Warning: move_uploaded_file(/var/www/iklanbaris//var/www/iklanbaris/wp-content/uploads/1022693-couple-heartbreaker.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in /var/www/iklanbaris/wp-content/plugins/wordtube/wordtube-admin.php on line 963

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ‘/var/tmp/phpTeNIW0’ to ‘/var/www/iklanbaris//var/www/iklanbaris/wp-content/uploads/1022693-couple-heartbreaker.jpg’ in /var/www/iklanbaris/wp-content/plugins/wordtube/wordtube-admin.php on line 963

    Unable to change permissions for file /var/www/iklanbaris//var/www/iklanbaris/wp-content/uploads/1022693-couple-heartbreaker.jpg!

    Can anyone help me, please…

Viewing 9 replies - 1 through 9 (of 9 total)
  • Well, I have the same problem with one of my hosting companies. It took the tech’s there all day to figure out how to fix the problem. (well almost) I can upload media clips now, but there is still a problem playing them….

    enough rambling, the fix is to remove ABSPATH from lines 37 and 41 in the wordtube-admin.php

    if nothing else it’s a start.


    I have the same problem. Got the error, and then when I removed the ABSPATH from the wordtube-admin.php page the error went away … however, no files are able to be uploaded.

    I have to upload them by hand, and then type in the path in order for it to play through the plugin.

    Any info or support on this issue would be great.

    Add me to the list. i get the exact same error message. I’ve tried messing with the ABSPATH…and yes, it shows the file as uploaded, but it doesnt work. It actually uploads the file the the wp-admin directory.

    OK, I got it to work. This is what I did:

    Edit wordtube-admin.php
    1. I removed ABSPATH from line 37
    2. Then on line 38 I replaced the get_option(‘upload_path’) with the actual upload path.

    Simply Replace This:

    if ($this->options['usewpupload']) {
    			$this->wptfile_abspath = ABSPATH.get_option('upload_path').'/';
    			$this->wp_urlpath = get_option('siteurl').'/'.get_option('upload_path').'/';

    With This:

    if ($this->options['usewpupload']) {
    			$this->wptfile_abspath = get_option('upload_path').'/';
    			$this->wp_urlpath = get_option('siteurl').'/wp-content/uploads/';

    Works for me, i’m happy.

    Yep, that does work fine !
    Thanks a lot !

    This seems to work in WordTube 1.6 but not in WordTube 2.0



    There is a much easier fix. Go to settings, then miscellaneous. If your full url path is empty it may be confusing your system, even though it says that it is optional. I just copied the info from “store uploads in this folder” into my full url path and it fixed my problem.

    I’m not sure if this thread is still active but for the sake of others stumbling upon this thread facing the same issue, I think I’ve closed the net on why wordTube is failing.

    After a media file upload it tries to chmod the uploads folder to a permission it likes, namely 0666. After it’s done this, it faces problem writing to the uploads. (Talk about shooting yourself in the foot).

    I’m using WordPress v2.6.3 and (I believe) v.1.6 of WordTube. You’ll find the following bit of code in <plugins>/wordtube/admin/functions.php.
    @chmod ($upload_path_video, 0666) or die ('<div class="updated"><p><strong>'.__('Unable to change permissions for file ', 'wpTube').$upload_path_video.'!</strong></p></div>');

    Lines change and don’t make good pointers, so I’ll refrain from giving you an exact line number. (In my functions.php, it’s around line 138. Do a string search. You’ll find it).

    Now, why it needs to do this is beyond me. Why not rely on WordPress’ own permissions management?

    The options facing you I think are two-fold.

    1. To use more relaxed file permissions chmod i.e. NOT 0666 but 0707 instead
      @chmod ($upload_path_video, 0707) or die (‘<div class=”updated”><p>‘.__(‘Unable to change permissions for file ‘, ‘wpTube’).$upload_path_video.’!</p></div>’); OR
    2. To remove the line completely so it NEVER tries to change/set the dir permissions on the uploads folder i.e so they remain in tact as original from the WP install

    I’d prefer not to open that can of worms and incur the wrath of web hosters by opening up potential security holes by changing folder permissions, so I’ve just commented the line out completely. The original permissions on the uploads folder are good enough for me. 🙂

    I hope that helps someone.



    I just can’t see anything in Firefox, everything seens to be working fine except display in firefox

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: wordTube] Can’t Upload Media Files’ is closed to new replies.