Support » Plugins » [Plugin: Stats] resolves to local test environment

  • I created a complete clone of my site on a local VM to use as a test environment. At some point, I gave this VM access to the internet in order to install a large number of updates. That was big mistake.

    It seems that when I did this, the address for my was updated to the IP address of the local VM – replacing as the destination. Now all of my new shortlinks point to a random IP address instead of my live site, even when I get the shortlink when logged into the production environment of my site.

    You can see this in my twitter stream: for recent updates.

    I have since completely removed the “ Stats” plugin from the test environment, but cannot work out how to get the url to revert back to pointing at the real site.

    I have had a look at this thread:

    I couldn’t find any reference to the IP address in wp-admin/options-general.php or header.php.

    When I look at ‘my blogs’ on the dashboard, I can see that still points to the wrong place, but I can’t find any way to manually update it.

    Any help would be greatly appreciated.

Viewing 1 replies (of 1 total)
  • Ok, I’ve fixed this to some extent by removing the stats plugin from my real blog and reinstalling it. When I reconfigured it from scratch, it let me add a new blog to ‘my blogs’ on and shortlinks are working again.

    However, if anyone else is going to do this, bear in mind that you’ll lose all your stats. Also, there’s probably no way to update the handful of shortlinks that were published on twitter before I noticed this problem, is there? They still point to the wrong server.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Stats] resolves to local test environment’ is closed to new replies.