[Plugin: WordPress.com Stats] Dead since 2.7 upgrade (20 posts)

  1. carl_in_florida
    Posted 7 years ago #

    Upgraded to 2.7 stats no longer collecting.


  2. AndrewRH
    Posted 7 years ago #

    Similar here - worse, though: now have two stats for same site (one that used to work and now doesn't and a new one which just started since upgrade to v2.7).

    Is there any way to merge two identically named stats?


  3. RobertoK
    Posted 7 years ago #

    Same problem here.

  4. starapple
    Posted 7 years ago #

    Installed Stats with WP 2.7 and no stats. That means nobody's visiting?

  5. William Bowles
    Posted 7 years ago #

    This is not the only confusing thing about this problem as the same problem is being aired in at least three different locations!

    Apparently the 'right' place is:


  6. AndrewRH
    Posted 7 years ago #

    Sorry, Creative-i, that link is to forums for the wordpress.com site (where they host your blog). This forum is for the self-hosted blogs which get the wordpress software downloaded from wordpress.org (not .com).

    And that forum topic was about logging into stats at .com. The problem described in this thread is about stats not being collected in the existing .org login; and sometimes a new (duplicate) entry being shown for the same site.

    e.g. My website has two sets of statistics - first is http://www.reeves-hall.net statistics up to the day I upgraded to WP 2.7; and the second is for a duplicate http://www.reeves-hall.net which collects stats from that upgrade date forward.

    I still hope to learn from someone here how the two identically named wordpress blog statistics can be combined into one. Anyone?


  7. William Bowles
    Posted 7 years ago #

    sorry, you've got it wrong, when you log in via the dashboard to view stats (or, as I'm trying to do, install a plugin), the link is to dashboard.wordpress.com.

    And these threads are going nowhere, there are now at least three of them all dealing with exactly the same issue, and not a straight answer anywhere from anyone, least of all from wordpress.


  8. Dgold
    Posted 7 years ago #

    For me, in a fresh install of WP 2.6 just upgraded to 2.7, WordPress.Com Stats plugin (on my self-hosted .org install described above) recognizes my API (same API that is running Akismet) and says it's already associated with another blog (my WP.com blog and a couple other self-hosted). I click "Add", and it says "Missing API Key". I re-enter it > try again > same thing.

    Anyone else seeing this?

  9. EricWordPress
    Posted 7 years ago #

    Same problem -- WordPress.com Stats just stopped working. But I don't see anyone coming up with a solution.

    I upgraded WP to 2.7. Everything went smoothly.

    However, WordPress.com Stats (http://wordpress.org/extend/plugins/stats/) stopped working.

    * The years of stats history data are gone.
    * The program has stopped collecting traffic data.
    * The stats graph -- whether set for days, weeks, or months -- just shows a "flat line".

    When is someone going to address this? WordPress.com Stats is one of the most popular plugins for WordPress. So this is CLEARLY an issue for a lot of people.

    Has anyone seen a link to a solution? Or where someone is at least trying to address the problem?

    Any and all assistance greatly appreciated! Thanks!

    -- Eric

  10. caseyfern
    Posted 7 years ago #

    Since upgrading to 2.7, I get a big red box telling me
    Error from Last API Attempt.
    Missing API Key.

    'An API Key is present in the source code but did not work.'

    The API Key is the same as I was using before.

    There is no place on this page to enter or modify anything, and I'm not finding a settings page aside from this (under Plugins).

    Assistance appreciated!

  11. caseyfern
    Posted 7 years ago #

    Actually I might have figured out the solution.

    Even though I had the most current stats.php in place, I deactivated the plugin, manually erased the file from wp-content/plugins/, then downloaded a brand new fresh version and uploaded.

    Once uploaded, I did -not- hardcode the API key in place.

    I reactivated in Plugins. When I got the big red banner at the top of plugins page, I clicked on the link to provide assistance, pasted my API key where indicated.

    At the bottom of the page it asked me if I wanted to Replace Blog (misleading text, but I did it anyway). On save, I was asked to login to WP again.

    Once I logged in, I saw some of my old data. Naturally it's not up to date since the 2.7 upgrade, but nonetheless, it recognized me and gave me back old incoming links info.

    I urge you to try this - MANUALLY delete the old copy, install a fresh one, follow the prompts, and replace blog with the same blog.

  12. Arnoud
    Posted 7 years ago #

    I think I may have found a suitable solution.
    It doesn't involve uninstalling, just editing a value your blog's database.

    Here is how it works:

    Login to http://dashboard.wordpress.com/wp-login.php
    In the left menu click "Blog stats"

    In the top right corner there is a dropdownlist that shows you the (duplicate) entries for your blogstats.
    Select (the correct) one and click switch.
    Notice the URL change in the title bar!

    The URL will change into something that ends with the ID of your blog.
    For example:

    Copy paste the number!

    Now the tricky part:
    Open up phpAdmin (or what ever tool you use to edit your database).
    Open the wp_option table
    Look for the stats_options value.
    Open this value and edit it.

    It will look similar to this:


    Notice the blog_id value, it's 9876543.
    Change this number into the value of the correct blog stats, in my example it's 1234567.

    Save the value. And you're done!
    Your stats will now be logged to the stats you've had before upgrading your blog.

    Also change your profile @ WordPress.com and select the correct stats in the primary blog setting on your profile page.

  13. AndrewRH
    Posted 7 years ago #

    Hi Derice,

    I didn't see the URL change in my non-wordpress.com hosted site (i.e. I self-host wordpress). However, I found that info you talked about by doing a View->Page Source from firefox. I searched for "blog=" and found a line like this:

    <iframe id='statsreport' frameborder='0' src='http://dashboard.wordpress.com/wp-admin/index.php?page=estats&blog=XXXXXXX&noheader=true'></iframe>

    (where XXXXXXX is actually the duplicate blog stat created in error by the stats program)

    I copied the URL and opened it in a new Firefox tab. I then selected the other stat page for my site (the original one with all the stats up to the point that the error occurred) -- this time the URL was changed and I saw the blog ID of my original set of stats (e.g. YYYYYYYY).

    I updated my database as you said, but I didn't know what you meant in your last paragraph -- I could not find anywhere in my wordpress.com profile that let me select a primary blog.


  14. Arnoud
    Posted 7 years ago #

    I have a double entry for my website in my wordpress.com profile.
    As I only have one account I can't check if this is the case for others as well.

    Given your reply, I assume it's not.
    That's also probably the case for not noticing the URL change.
    I also have a self hosted site. The view source methode you mentioned works just as good! It's the number that matters.

    I'm glad it worked out for you! :)
    (And hopefully others as well!)

  15. Maryj2007
    Posted 7 years ago #

    I've got the same problem as carl_in_florida. I upgraded to WP 2.7 and the stats plugin stopped working.I admit that it was my favourite plugin! At first I thought everyone had deserted my blog, but then I looked at Google Analytics and found that people are still visiting.

    Can't anyone give a simple way of fixing the plugin? there must be a lot of people who are missing this fantastic plugin!

  16. mycee
    Posted 7 years ago #

  17. lhutmacher
    Posted 7 years ago #

    i had this same problem & it was because of this:

    theme must have a call to <?php wp_footer(); ?> at the very bottom right before the </body> tag.

  18. bubersson
    Posted 7 years ago #

    Hi Derice, I've just tried to edit sql database (at my web http://thaicrew.cz ) and it worked. Now I'm able to run wordpress stats (before I was in that never-ending loop), but now I see only stats from wordpress.com account and I can't switch them to my external thaicrew.cz page.
    How did you do it?
    Is there a way to register external page to wordpress.com?
    I've used your options setup (with my numbers):
    So maybe if you could post the stats_options for the external pages it would help us. Thanks a lot.

  19. passthepopcorn
    Posted 7 years ago #

    hi folks. i'm going to ask a really dumb question, pardon me, but i'm a novice: i have a wordpress.org blog installed on my hosted site. when i go to my site, i'm confronted by my blog's front page and i need to login. but my problem is: each time i do this, my stats record me as a visitor, because technically i am. how do i sort this out? i must presumably sort this out with my webhost?
    thanks in anticipation

  20. gwalter
    Posted 6 years ago #

    I realize this thread is a bit old, and we're now up to v.2.8.x, but I was able to follow @Derice's advice above - unfortunately, I still got error messages.

    Frustrated. Fortunately I have Google and Woopra stats - but I would sure like to incorporatethe two years of data from my wp.com hosted blog.


Topic Closed

This topic has been closed to new replies.

About this Topic