WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress-to-lead for Salesforce CRM] Form not processing to Salesforce

[Plugin: WordPress-to-lead for Salesforce CRM] Form not processing to Salesforce

  • phendyr
    Participant

    @phendyr

    Hello,
    I’m testing the WordPress-to-Lead for Saleforce plugin on a new client site, and I have their organization ID set, as well as my form built within the plugin and added to a page.

    When I submit the form and opt in to receive a copy, I receive the email just fine, but when I check the SF account, I do not see any new lead with my name on it.

    Two things I notice from previous posts about this plugin:

    1) when viewing page source, I see the form has no action= tag
    2) the field names are prefixed with sf_ is that correct?

    lastly, for any custom fields I create, do I have to create them within Saleforce as well?

    Thank you for your time and help.

    http://wordpress.org/extend/plugins/salesforce-wordpress-to-lead/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Rami
    Member

    @ramiabraham

    Hi phendyr,

    Just another user of the plugin here… I don’t know about the first question, but I do know that you have to create the fields in salesforce as well, and should match your site exactly. In SF, click on your name –> setup –> customize and pick your option (usually Leads).

    My fields are not presently prefixed with sf_

    Hope this helps!

    Plugin Author Nick Ciske
    Participant

    @nickciske

    When I submit the form and opt in to receive a copy, I receive the email just fine, but when I check the SF account, I do not see any new lead with my name on it.

    Then your org id, or fields are not setup correctly.

    Two things I notice from previous posts about this plugin:

    1) when viewing page source, I see the form has no action= tag

    A blank action means the current page (this is not a bug).

    2) the field names are prefixed with sf_ is that correct?

    Which field names?

    lastly, for any custom fields I create, do I have to create them within Saleforce as well?

    Yes, the plugin merely passes the data to SF. If there’s nowhere for it to go (or the field names do not match exactly) the data gets discarded. It cannot create fields.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WordPress-to-lead for Salesforce CRM] Form not processing to Salesforce’ is closed to new replies.