WordPress.org

Support

Support » Plugins and Hacks » WordPress Sphinx Search Plugin » [Plugin: WordPress Sphinx Search Plugin] Plugin fails due to missing tables

[Plugin: WordPress Sphinx Search Plugin] Plugin fails due to missing tables

  • The plugin is trying to use wp_sph_counter, which does not exist (and is not created by the plugin). I suspect this is an old table that was removed in 3.1?

    root@BlogTest2:/srv/blog.photobiz.com/sphinx# /usr/bin/indexer –rotate –all
    Sphinx 0.9.8.1-release (r1533)
    Copyright (c) 2001-2008, Andrew Aksyonoff

    using config file ‘/etc/sphinxsearch/sphinx.conf’…
    indexing index ‘wp_main’…
    ERROR: index ‘wp_main’: sql_query_pre[1]: Table ‘photobiz_blog.wp_sph_counter’ doesn’t exist (DSN=mysql://pbblogweb:***@localhost:3306/photobiz_blog).
    total 0 docs, 0 bytes
    total 0.010 sec, 0.00 bytes/sec, 0.00 docs/sec
    indexing index ‘wp_delta’…
    ERROR: index ‘wp_delta’: sql_query_range: : range-query failed: Table ‘photobiz_blog.wp_sph_counter’ doesn’t exist (DSN=mysql://pbblogweb:***@localhost:3306/photobiz_blog).
    total 0 docs, 0 bytes
    total 0.010 sec, 0.00 bytes/sec, 0.00 docs/sec
    distributed index ‘wp_’ can not be directly indexed; skipping.

    Also, there is no option in the plugin to simply generate the config for a system-wide install. I have to do that manually by running ‘php sphinx.conf’ which seems a bit silly. I also don’t like that Apache can read the Sphinx indexes – there should be an option to skip that (no need if using the system wide installation of Sphinx).

Viewing 15 replies - 16 through 30 (of 30 total)
  • Which Sphinx Search version are you using?

    0.9.8.1-2 (the version that ships with Ubuntu 10.04)

    New version required 0.9.9 at least.
    Setup it and all should start working.

    Ah that explains that. Sure enough, upgraded and it works like a champ! Thanks!

    I did notice one issue, and perhaps it’s just my setup or WordPress itself, but I am trying to add:

    <span style=”text-align: #ffff00;”>

    To the “Before keyword” settings and something is escaping the quotes and mangling the field in the admin panel. I haven’t looked into the cause yet so it could very well be my setup (though magic_quotes_gpc is off) but wanted to share.

    Otherwise, it’s working great and is SOOOO much faster than the built-in search features. Thanks for all your help!

    Yes, maybe there are some problem with escaping.
    As workaround I suggest to try without quotes:

    <span class=coloryellow>

    Add class coloryellow to the styles.css:

    span.coloryellow{
    color: #ffff00;
    }

    BTW, you used text-align and specify the colour as parameter – it’s not correct.

    Hah yes you’re absolutely right. I meant ‘text-color’. The work-around seems to work though only for the headers. Something is up with trying to use the span within content but that’s likely to do with our (very customized) theme.

    Everything is looking great thanks again! If you’re going to be at the MySQL Conference next week, we should meet up some time – I’ll buy you a beer 😉

    I’ll create an issue about quotes.
    I would like to be there, but I am far away.
    Anyway thanks!

    I have compiled and installed Sphinx here at /usr/local/sphinx
    But the plugin fails to detect it when looking for the binaries and only gives me the option to install to the WordPress upload directory. I want it to use system install. Suggestions please.

    OK,I thought I would be tricky and soft link sphinx to where your plugin expects to find it.

    home/fvisions/public_html/wp-content/blogs.dir/1/files/sphinx

    However the plugin still claims it can not find indexer or searchd.

    I have checked and they both exist at that location now under /bin.

    So it is still not working. 8(

    Hi Leo,
    what about plugin folder, did you install it also us soft link ?

    Also, you can try to copy searchd and indexer into /usr/bin directory.
    Then run wizard again, it should detect it as system binaries.

    Hi Yaroslav. No, the plugin was installed normally via upload with FTP to the plugins directory and then activated through the WP admin.

    I also followed your suggestion and created a soft link to indexer and searchd in /usr/bin. Still no success.

    What now?

    ah, OK, I’ve figured out why your plugin is failing.

    escapeshellcmd() and exec() have been disabled for security reasons.

    It would be good if you rewrote your plugin to allow people to manually set the path when they know the exact location when the automatic search or install fails. This would prevent the setup failing when the server security prevents certain PHP commands from being used.

    Now, how do I set your plugin’s configuration without the wizard?

    I temporarily edited the php.ini and allowed escapeshellcmd() and exec().
    I ran the wizard. Yay! past step 2.
    However I then had to manually create /sphinx/var and child directories where the wizard was expecting them.
    Now I’m at the point where I have the following error. “Indexer: configuration files not found.”
    So reading your “readme.txt” and the question and answer, I’ve arrived at the conclusion that escapeshellcmd() and exec() will have to be permanently allowed in PHP for your plugin to work… correct?

    “Indexer: configuration files not found.”

    It means that www-data user haven’t enough permissions to read/execute searchd, indexer or sphinx.conf.
    Check permissions of those files.
    Or it means that plugin can’t find those files. Check paths to them.

    I will include ability to manually set the path in next release.

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘[Plugin: WordPress Sphinx Search Plugin] Plugin fails due to missing tables’ is closed to new replies.
Skip to toolbar