WordPress Social Login
Issue when WP is installed in subdirectory (2 posts)

  1. Incendiary
    Posted 3 years ago #


    The plugin fails to install when WordPress is installed in a subdirectory (e.g. http://www.example.com/wp) but accessed via the root (www.example.com).

    Line 86 in wp-social-login.php appears to be the culprit. Replacing

    require_once( dirname( dirname( dirname( dirname( __FILE__ )))) . '/wp-load.php' );


    require_once( ABSPATH . '/wp-load.php' );

    Allows the plugin to install. If this is a valid fix, I'd appreciate it if you could include it in a new release as we'd like to include the plugin via svn:externals without third party edits. If this has any unintended consequences I'd happily work with you to resolve them.

    Edit: The problem also exists on authenticate.php, line 37 - although this will have to be resolved in a different way.



  2. JayCC
    Posted 2 years ago #

    This bit us as well, we've moved our wp-content directory to a different location (so we can use an svn:external for the wordpress core files). So far all the plugins we've used have been fine, but this assumption used in this plugin causes a require_once fatal error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Social Login
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.