Yoast SEO
[Plugin: WordPress SEO] Canonical URL not working with Custom Post Types (3 posts)

  1. Trendwerk
    Posted 5 years ago #


    I am using the WordPress SEO plugin on multiple websites with Custom Post Types. On the arichive page of a posttype (archive-posttype.php), the canonical URL displays the homepage URL of the website. This disables this page to indexed by search engines.

    Is there any way to display the correct canonical URL, or is there a way to disable canonical URL on this page or on the entire site so the page can be indexed?

  2. Joost de Valk
    Plugin Author

    Posted 5 years ago #

    This is fixed in the latest release, 0.3.5, if all is well. If not, please do let me know here.

  3. Trendwerk
    Posted 5 years ago #

    It doesn't seem to do the trick for us. I e-mailed you a few days ago with the URL of the website where it goes wrong. As you can see, we installed the new version of WP SEO here, but the canonical URL is stil wrong.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic