Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] WordPress SEO caused my site to display just white?

  • Hi guys, I installed the WordPress SEO Plugin a while back and loved it. Mid June my site just started displaying white – I could go into Wp Admin and do everything normal, but in the web browsers there was only a blank page displayed. After getting in touch with my hosting company, they checked the issue and came back saying that the plugin “WordPress SEO” was causing the issue. I had to disable the plugin and have been too scared to use it again, even though I think it should be ok.
    I just wanted Joost to know that there was an issue and it should maybe get checked. Cheers!

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 16 through 30 (of 43 total)
  • Thanks JowiM. It fixed the error.

    @jowim – how do I do that? I never use code and don´t know where the file system is! Can you help with more info please, I´m so worried.

    Thanks, JowiM ! Solved my Internal Error 500 after installing latest Yoast

    If you are not comfortable editing the plugin’s files, FTP into your site (or use whatever file management application your host provides) & rename:

    wp-content/plugins/wordpress-seo

    to:

    wp-content/plugins/wordpress-seo-old

    This will deactivate the plugin and allow you back into your site.

    @ingervandyke you have to connect to the server using an FTP account. Once you done that you go to {wordpress-path}wp-content/plugins.

    awesome, thanks JowiM 🙂

    For the new users, best method is to use the File Manager in your host account’s cPanel. Then navigate to :

    public_html/YOURSITE/wordpress/wp-content/plugins/wordpress-seo/admin

    to find the file : class-admin.php

    then select CODE EDITOR, and remove the ‘s’ as detailed above.

    OK so I have downloaded Filezilla but have no idea how to set this up for my site. Do I have to contact my host?

    Would that be my Hostgator account?

    @cecy: For your FTP? Yes.

    @ingervandyke: Yes. Or ask them if they have a file management application you can use instead.

    A big thanks to Thanks JowiM for this perfect solution
    You save a lot of our time

    Thanks, JowiM, your solution worked.

    This just happened to me. Got into File Manager, found the class-admin.php and removed the “s”. Now I get this error:

    Parse error: syntax error, unexpected T_GLOBAL, expecting T_FUNCTION in /home/malbarvi/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 508

    Thanks folks! Saw the fatal error on everything I was trying and panicked a bit but your solution worked brilliantly!

    Many thanks in advance for your help, well now that my blog is up and running as promised…

    @johnheaston is it possible that you may have deleted the bracket or something similar?

Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] WordPress SEO caused my site to display just white?’ is closed to new replies.