Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Title Issue

  • Hi, in using this plug-in the title at the top of the page (sorry I am not tech savvy when it comes to blogs) displays like this:
    “How To Use TriberrTo Become A Writer”
    As you can see, it does not put a space between the blog post title and the title of the blog itself.
    How do I fix this? And please, if you say something like “put this code in the header” or something like, please walk me through how to get to that place πŸ™‚ It will save me a lot of time trying to find where to make the fix.
    Many thanks, I’m still trying to figure out a lot, but I do like the plug-in.
    Renee

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Under SEO >> Titles

    In the “Post” section under “Title template” you need the following
    %%title%% | %%sitename%%
    With this you have the pipe ( | ) seperator, but you could change this to whatever you like such as a hyphen ( – ) or whatever you like.

    If this doesn’t fix your problem, make sure that in your theme’s header.php file your title tags look like this
    <title><?php wp_title(''); ?></title>

    Forgive me, I’m not an expert here.
    When you say in the post section under “Title Template”, where do you mean? On “Homepage Title Template”? or where? there are numerous places to put this code.
    Also (I’ve run into this before), many will say “in your theme’s header.php” change etc – but no one says where to find this. I’ve searched on the Internet and can’t find this – where do I go?
    I did try to put the code on “Homepage Title Template” but it didn’t change anything so I am lost. My apologies if this is basic and I’m missing it.

    go to your wp-admin – appearence – theme editor there you will find your header.php file

    yes, but where in here? If I go into theme, there is no header.php file. I am running Twenty Ten 1.2 by the WordPress team and in the theme page, there are links to widgets, menu, background and header, but I don’t see a header.php file anywhere.

    Never mind found it πŸ™‚ Let me see if I can get this to work, thanks!

    I don’t want to mess this up, here’s what’s in the title tag

    <title><?php
    /*
    * Print the <title> tag based on what is being viewed.
    */
    global $page, $paged;

    wp_title( ‘|’, true, ‘right’ );

    // Add the blog name.
    bloginfo( ‘name’ );

    // Add the blog description for the home/front page.
    $site_description = get_bloginfo( ‘description’, ‘display’ );
    if ( $site_description && ( is_home() || is_front_page() ) )
    echo ” | $site_description”;

    // Add a page number if necessary:
    if ( $paged >= 2 || $page >= 2 )
    echo ‘ | ‘ . sprintf( __( ‘Page %s’, ‘twentyten’ ), max( $paged, $page ) );

    ?></title>

    where do I add the code?
    Thanks!

    Replace all of that with
    <title><?php wp_title(''); ?></title>

    primitvenet, I replaced the code and it worked but I have another question πŸ™‚
    Before it said “How To Use TriberrTo Become A Writer”
    Now it just has the the title of the blog post (so “How to Use Triberr”)
    From an SEO standpoint, does this matter?
    Many thanks to you and kletskater for your help!

    In Settings >> General
    What have you got under Site Title and Tagline?

    Under SEO >> Titles
    Did you put the following in the Post section under Title Template?
    %%title%% | %%sitename%%

    The title should read:
    How To Use Triberr | To Become A Writer

    Oops, I had that, then took it all out when things didn’t work. I’ll add it back in. Thanks for helping a newbie πŸ™‚

    Actually, that didn’t work…I put it under SEO – Titles – Post – Title template.

    Hmmm…

    What’s your URL?

    And what have you got in Settings >> General >> Site Title and Tagline?

    Do you have any caching plugins enabled? eg. WP Super Cache or W3 Total Cache?

    http://tobecomeawriter.com
    Site Title: To Become A Writer
    Tagline: Blog home of master wordsmith RenΓ©e Pawlish, author of mystery novels, horror books, and the Writers Workshop.

    This shows up if you’re on the main page, but if you go to a link, it just shows the title of the blog post – it’s fine, better than:
    How To Use TriberrTo Become A Writer but if it negatively affects SEO, I would want it different πŸ™‚

    Hmmm… this is odd.

    Try ticking the “Force rewrite rules” under SEO >> Titles
    It’s not a perfect solution, but should work if you’ve got the right stuff between your <title> tags and in the SEO >> Title form.

    This may sound obvious – but under SEO >> Titles you are scrolling down to the bottom of the page and hitting save after making the changes, right?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Title Issue’ is closed to new replies.