Support » Plugins and Hacks » Yoast SEO » [Plugin: WordPress SEO by Yoast] The latest update is broken

  • Resolved ssiddiqi1

    (@ssiddiqi1)


    The latest update is broken. I have to revert to previous version from backup. I cannot acccess my Admin Pane after updating. It gives an error
    Fatal error: Call to undefined function update_options() in /home/ssiddiqi/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 16 through 30 (of 33 total)
  • Same issue here, access to WP admin is broken…

    And ssiddiqi1 posted the right fix. 1000 thanks !

    Update 1.28.1 fixed all 1.28 errors I encountered

    If you cannot access your wp admin panel, how are you supposed to install the fixed version of the 1.28.1 plugin? I have access to edit the files through my c-panel, but it doesn’t appear I can simply disable a plugin there. I’d rather not loose all the settings if I can help it. Anyone care to offer suggestions on how to disable the plugin from file manager or what to edit in the admin_class.php file to get into the wp admin panel to open again? Thanks in advance for your help.

    If you rename the plugin folder for wdpress seo to something like wordpress seo1 in cpanel it then disables the plugin. You can then make the change to the file on line 441 – and then go back to the original name. This should theoretically work ….,

    tash46

    Thanks tash46, do you know what needs to be corrected on line 441?
    rtech451

    You can ftp to your /wp-content/plugin/wordpress-seo/admin/ download admin-class.php to your desktop by ftp and edit the admin-class.php
    On line 441, chanhe update_options to update_option, then upload the file to the /wp-content/plugin/wordpress-seo/admin/. Or, use the version 1.2.7 from your backup.

    The file name is actually class-admin.php.

    Thanks, ssiddiqi1. Your fix worked great! I was able to access the dashboard on update the plugin.

    Thanks ideafarmer… that did it!

    Ok so fix has sorted out the disablement of the wp-admin (which was a bit of a critical error and oversight to say the least), but now it states that there is an error with this code in my header.php … any ideas what appears to be the problem with this as looks fine to me?

    <meta name=”description” content=”The definitive London luxury lifestyle guide, covering all the latest luxury news and calendar events, providing a range of exclusive member-only privileges to help you explore the worlds best hotels, restaurants, nightclubs and unique experiences” />

    Following ssiddiqi1’s advice should solve the problem!

    You can ftp to your /wp-content/plugin/wordpress-seo/admin/ download admin-class.php to your desktop by ftp and edit the admin-class.php
    On line 441, chanhe update_options to update_option, then upload the file to the /wp-content/plugin/wordpress-seo/admin/. Or, use the version 1.2.7 from your backup.

    For those who still can’t access their WordPress backend, have a look at http://cool-tricks.net/call-to-undefined-function-update_options for a detailed solution 🙂

    Download version 1.2.8.1 through your Web broswer and Ftp it to you Wp installation wp-content/plugins/. It will overwrite your version 1.2.8. You should be able to access WP Admin Panel.

    I’m not able to use the wysiwyg editor any longer. The tab is grayed out. Anyone else have this after the upgrade? I went from 1.28 to 1.28.1. It was working prior to the 1.28 upgrade.

    Mark

    SEO has nothing to do with WYSIWYG editor. Did you check your profile under User>your profile, if IDsable Visual Editor box is checked by mistake?

    My sitemaps are currently 404 with all versions of 1.27, 1.28 and 1.28.1 after upgrading to 1.28 from 1.27, then to 1.28.1 then back to 1.27

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] The latest update is broken’ is closed to new replies.