Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] The latest update is broken

  • Resolved ssiddiqi1

    (@ssiddiqi1)


    The latest update is broken. I have to revert to previous version from backup. I cannot acccess my Admin Pane after updating. It gives an error
    Fatal error: Call to undefined function update_options() in /home/ssiddiqi/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 1 through 15 (of 33 total)
  • I’m having the exact same issue. I can get to my dashboard, but I can’t access plugins.php, widgets.php, and so on. The site looks fine, but the plugin has broken much of my dashboard functionality.

    Since I often auto-update my plugins with desktop software, this could have been a horrendous problem across my sites.

    I’m using the current version of WP, editing from Windows 7 Home, and most of my themes are based on Artisteer, if that makes any difference.

    same same same. Can’t access the dashboard. Joost de valk did it wrong this time :/

    How to overcome now? Have to delete the plugin from CPANEL? and reinstall??
    will it remove the settings and all? :O

    You can ftp to your /wp-content/plugin/wordpress-seo/admin/ download admin-class.php to your desktop by ftp and edit the admin-class.php
    On line 441, chanhe update_options to update_option, then upload the file to the /wp-content/plugin/wordpress-seo/admin/. Or, use the version 1.2.7 from your backup.

    Yes, for many people, the simplest solution is to delete the plugin via cPanel > File Manager > wp-content > plugins

    I didn’t have a backup copy of 1.2.7, so I’m not sure if everything has been lost from the settings, but — in most cases — restoring after this kind of issue means the settings are still in the database.

    If you delete the plugin and don’t restore (or revert to) with 1.2.7, you may need to re-edit your Header.php so your website title shows up again at the top of your browser.

    I’m hoping this plugin is fixed, quickly.

    hmmm looks like time to go back to all in one 🙁

    Me too.

    Anyone got v1.2.7 I can put back on?!

    I’m running WP v3.3.1 (I know!) but update does say works from v3.1 upwards … !

    Why not just edit the admin-class.php? Anyway, if you want you can download my fixed version 1.2.8 from http://www.shaadiconnections.com/wordpress-seo.zip. I will delete it as soon official version is fixed at the WordPress, so it only as interim solution.

    It’s always the same thing with new updates of this plugin!!

    Even this time sitemaps are blak!!

    I’m getting fed up!!!

    Sitemaps are not blank. Are you sure, you did not make mistake when configuring sitemaps

    Phew! thanks, ssiddiqi1, your fix appears to have worked! Very quick solution!

    At least, admin now works. We’ll see whether the plugin generally operates as I’m used to!

    It got resolved, automatically.

    @theonlyanil
    WHat do you mean by got resolved automatically? A bug in the code does not resolve automatically. The new version 1.2.8.1 was released with the fix. You must have updated it.

    After uninstalling the plugin, I saw Anil’s post and re-installed what’s still described as 1.2.8.1. It seems to be working now. I’m not sure why, and I’ve only tested this with one website so far, but it does look like the problem has been resolved.

    [Update: I tried the update on a second website, and it worked fine on the first try.]

    I’d have been a lot happier if the fixed plugin had been renamed 1.2.8.2, or something like that.

    @ssiddiqi1 I don’t know how did it resolve automatically. I was refreshing the dashboard every minute and didn’t delete or update anything in Cpanel as I didn’t want to lose the settings.

    After a few page reloads I got access to WP dashboard.

    UPDATE: WordPress automatically deactivated and deleted the plugin.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] The latest update is broken’ is closed to new replies.