Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Stripping /category/ sometimes require resaving

  • On a few of my clients I noticed that the stripping of /category/ stops working. I’m not sure if it’s something they had done or changed and that’s why I’m posting on here.

    The box will be already checked but the links don’t work. I need to uncheck it, save, then recheck it and save again. Then it starts to work.

    Any reason why? Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Got hit with the same problem after upgrading the plugin – as you said turning off category removal, saving settings and then turning it on and saving again worked for me too.

    Still happening to quite a few people. Anything on this? I figured it might be a cache issue with W3TC but I’m not really sure.

    [ Please do not bump, that’s not permitted here. ]

    I have the same problem, and same solution except it stops working regularly.

    I resolved it by disabling that option and installing this plugin instead:

    No resolution on this. Seems to be an on going issue with most people who have this plugin and used this feature. Oh well.



    I am having the same issue where it stops working and I have to save settings in the Permalink Settings for it to work again. I will try the other no category base plugin for now until it is fixed.



    It looks like there needs to be a refresh rules put in place when a change is made to a category.

    I am not a coder but it looks to be something that could be implemented like in the WP No Category Base plugin (

    // Refresh rules on activation/deactivation/category changes
    register_activation_hook(__FILE__, 'no_category_base_refresh_rules');
    add_action('created_category', 'no_category_base_refresh_rules');
    add_action('edited_category', 'no_category_base_refresh_rules');
    add_action('delete_category', 'no_category_base_refresh_rules');
    function no_category_base_refresh_rules() {
    global $wp_rewrite;
    $wp_rewrite -> flush_rules();

    Looks like there was a fix in version 1.2.5. Going to keep testing this.

    just upgraded to 1.2.6
    having the same problem.

    creating new category breaks functionality.
    only fix as per OP: uncheck, save, recheck, save

    I had that problem with 1.2.5 and someone had recommended the WP No Category Base – WPML compatible plug in. I installed it and it’s fixed.

    Even after installing 1.2.6 I kept the other plug-in and my site is working fine so far.

    I’ve used WP No Category Base before and had moved to almost reliance on Yoast SEO.

    I’m hopeful Yoast will issue an update.

    I am having the same issue. On my site it breaks without making changes to categories. Sometimes I make a change to my theme options and it breaks. I find myself just randomly unchecking and checking the box everyday and saving settings. I have tried contacting Yoast on Twitter too, they don’t see to respond.



    You don’t even need to check and uncheck the box, just hit save on the Yoast SEO Permalinks page. That will recreate the proper links.

    Still not a solution, but thanks for the tip. This will make life a little easier.

    Just an FYI 1.2.6. was not working for me so I kept the plug-in mentioned above for the category issue I noted above and went back to 1.2.5. Thank God I had only updated one site.

    Glad to find this post, same problem here.
    Will use the suggested alternative plugin, untill a fix for Yoast’s SEO plugin comes available

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Stripping /category/ sometimes require resaving’ is closed to new replies.