WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress SEO by Yoast] Strip Category Base not working in 2.4

[Plugin: WordPress SEO by Yoast] Strip Category Base not working in 2.4

Viewing 15 replies - 16 through 30 (of 32 total)
  • Just happened to me today as well

    Upgraded to 1.25 when it came out and was working OK up till now

    Logged in tonight to Analytics having changed nothing on site all day, and 404 errors everywhere for all category pages.

    Switched strip the category base off and saved then sitched on again and is now working.

    But for how long? Really do not want to be checking for 404’s all day.

    It’s a great plugin, really hope this issue gets sorted quickly

    Yes – same problem here.

    My solution is: Uncheck the ‘category base checkbox’, save, check the ‘category base checkbox’ again, save. Now it should work again.

    For bugfixing: I noticed it breakes every time agan when I edit the description of a category.

    Greetings from Germany,
    Edward

    That solution doesn’t work for me. Categories and tags are both completely broken when I enable this plugin. Need to find an older version.

    Using 1.2.5 same 404 for categories from time to time. Toggling strip category on off works for a limited time. The best plugin around, hope this will be fixed soon.

    I’ve found that this works for me:

    • Turn off “strip category” function in Yoast
    • Go to Settings | Permanlinks and click save to restructure permalinks

    Echoing @edwardblack – Even the slightest change to any text on a Category page triggers the bug and the 404 errors for any category page.

    The page can be found if the base /category/ is added back into the URL.

    About to launch a site with 231 categories and was relying on WordPress SEO to strip out the /category/ for us. Would really like to see this fixed soon so we can launch and not have to use 301 redirects to fix links if we launch with /category/ included.

    Hey you all might be interested in this. One another open thread about this issue, a guy named Ismael posted a fix.

    I tried it and it works. It’s another plug-in that strips the category base.

    Agree with Miz.Michele – The “WP No Category Base – WPML compatible” plugin appears to work great.

    Yoast – hint, hint… ;^)

    The solution provide by EdwardBlack worked for me.

    @michael. Just an FYI – that had worked for me too – until I changed anything. If I made a post, added or edited a category – then the categories weren’t working again. and I had to re-save permalinks. So if the one time fix worked for you that’s great. It didn’t for me.

    I started to think I must be going crazy.

    Also having the same issue. I get it working, then the next time I check, it doesn’t!
    Will try the stripping plugin.
    ***************************************************************
    WP: 3.4.1
    Yoast SEO 1.2.5

    What I expect:
    Strip /category/

    What happens:
    Doesn’t strip /category/ and leads to 404 pages. However, the original link that includes /category/ DOES work.

    Problem Website:
    Squarespace Plugins

    Deactive, activate, SEO>Permalinks>SaveSettings

    — worked for me. Thank you!

    Site: Healthy Mind Heart Body

    Deactive, activate, SEO>Permalinks>SaveSettings

    This work.. But we need a permanent solution!

    Please!

    @liomar. I used a plugin for the category base so that’s now OK. For my tags, all of a sudden with this update, the tag descriptions stopped showing. Any advice?

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Strip Category Base not working in 2.4’ is closed to new replies.