Support » Plugins and Hacks » Yoast SEO » [Plugin: WordPress SEO by Yoast] Social: can't select page as Facebook admin

Viewing 15 replies - 16 through 30 (of 32 total)
  • swisss

    (@swisss)


    I’ve upgraded to the latest version 1.1.4 and am very disappointed to find that the fields where I had previously entered Facebook page ID and Facebook admin ID have disappeared (unless I’ve not looked hard enough) and I am now being forced to use a ‘WordPress SEO by Yoast’ app to enter this info.

    Like other users here I have many Facebook pages and as such I wish to continue using the ID fields as in the previous version. This was working perfectly and whilst I having nothing against FB apps and have several in use, I do not want to have to use a third party app for this purpose.

    Is it possible to downgrade / revert to the previous version of Yoast SEO that had the FB ID fields? Or is there a workaround?

    Many thanks

    audvin

    (@audvin)


    Experiencing the same bug. Only lists 7 Facebook Pages, same ones shows up every time, not random.

    I currently administer 3 Facebook pages and only one shows up for me as well.

    972 creative

    (@toddedelman)


    Has any solution been found here? I have many pages and apps I’m an admin of but the plugin only grabs one page. Please help! Incase needed, the username I have on Facebook is ../tedelman

    same here with 1.1.5. I have only one page and it does not receive it 🙁 I only have the option “Do not use a Facebook Page as Admin”

    Version 1.1.5 Social still doesn’t work BUT I think I have a workaround.

    You can do this 2 ways, either with phpMyAdmin or the plugin’s import/export feature. In either case, you need the FB Page ID. You can find it by visiting the Page you wish to make admin, click “Edit Info” and find the ID in the address bar.

    Next, go to the Social menu and set things up the way you want with using ANY Page. It doesn’t matter what Page you choose because you’re gonna replace the Page ID with the right one. Be sure to click Save.

    OK, now you have two ways to proceed. Just choose the one that’s easiest for you.

    1. phpMyAdmin

    In table wp_options, find option_name = wpseo_social. Edit it and look for fbadminpage followed by a long string of numbers in double quotes. Replace the long numeric string with the FB Page ID of the CORRECT page. Save and DONE! 🙂

    2. Import/Export

    Export the current settings, unzip on your local machine and edit the settings.ini file. Near the end, look for fbadminpage = “a long numeric string”. Replace the long numeric string with the FB Page ID of the CORRECT page. Save the file. Zip and save as settings.zip. Use Import feature (you may have to click the Social menu item again for it to reappear at the bottom). DONE! 🙂

    I hope this workaround helps those who have been waiting for a proper fix. Enjoy!

    Edward, I used your second workaround successfully.

    The feature to automatically pull the app id from Facebook is really neat but maybe it would just be easier to leave a blank field for the user to manually type the number in.

    I tried Edward’s second option as well, and replaced the string with the correct ID, unfortunately, all I got back was an empty field in the “Select a page to use as Facebook admin” drop-down so I’m not sure what I’ve achieved.

    I can also only see one page in the drop-down whilst I have a lot more on FB.

    Can’t we just add the ID in manually? I can’t get mine to select my page. I administer 13 and have 1 showing.

    +1
    I also tried Edward’s second option as well, and replaced the string with the correct ID, and the meta tag is now ok.
    I don’t expect the UI to work, but I haven’t checked.

    Hey Yoast!

    I have about 10 apps and 20 pages on my social account…WordPress SEO still only pulls 1 per page and application.

    Just wanted to drop you an update that the issue still is out there :/

    Any chance we could just get an option to manually enter the app id…kind of like how your analytics give you the option to automate our manually enter?

    Mike

    Same Problem here…

    Pages with numbers still doesn’t show . . .

    Adam

    (@robinsontb21)


    Same issue

    I am also encountering a similar problem. I’m trying to link my Facebook page (https://www.facebook.com/pages/Simp%C3%B3sio-de-Integra%C3%A7%C3%A3o-das-Ci%C3%AAncias-do-Mar/398227570211999) and it isn’t appearing on the page list. I have one guesse for possible cause: the use of non ASCII characters for the page title.

    I’d appreciate very much if somenone could give me some insight.

    Cheers,
    Sebastian

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Social: can't select page as Facebook admin’ is closed to new replies.