Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Sitemap shows blank – Google seems to read

Viewing 7 replies - 1 through 7 (of 7 total)
  • Anyone know why this sitemap shows a blank page? Thanks.

    I am having the same problem in Chrome with a new site and new install of Yoast (I use it successfully on many other websites).

    In Firefox, I get the following error message which may provide more help:

    Error loading stylesheet: An unknown error has occurred (805303f4)http://simplesimoncatering.co.uk/wp-content/plugins/wordpress-seo/css/xml-sitemap-xsl.php

    Google webmaster says the Robot text is blocking the site.

    Can you help? Thanks.

    I just noticed that in all 3 browsers it’s something different. After reading mpurse post, I checked in FF and i get this error:

    Error loading stylesheet: An unknown error has occurred (805303f4)http://maxcdn.pumpjunkies.com/wp-content/plugins/wordpress-seo/css/xml-sitemap-xsl.php

    In IE it just says text lines of:
    http://pumpjunkies.com/post-sitemap.xml 2012-10-11T18:55:02+00:00 http://pumpjunkies.com/page-sitemap.xml 2012-10-10T23:31:32+00:00 http://pumpjunkies.com/category-sitemap.xml 2012-10-11T18:55:02+00:00 http://pumpjunkies.com/post_tag-sitemap.xml 2012-10-11T18:55:02+00:00

    But again, in Chrome it’s blank. I wouldn’t be so worried but I thought I read somewhere that SEO wordpress is set up to be readable on the page along with acting as the sitemap too. And now with the error in FireFox, I’m, wondering if I have a problem. Plus Yoast’s own page looks like it’s the right way. He wrote the thing anyway so he would know. Here is how it should look in Chrome.

    http://yoast.com/sitemap_index.xml

    Any help is appreciated.

    I’m getting something very similar. FF is showing something similar to what you’re getting in IE, but blank in Chrome.

    Did you ever find a solution?

    No, I never did actually. I’m pretty sure Google is reading this “blank” sitemap though because in webmaster it says submitted and read. But weirdly on other sites I built on WordPress, all is fine and I can see the sitemap on the URL “sitemap_index.xml”. I just don’t know why it’s showing blank on PumpJunkies.com. If you ever figure this out yourself, will you reply here so I can fix mine as well? Thanks.

    Hi, I have the same problem. Blank sitemaps in source code. I am worried, should I be?

    Stefan

    Plugin Author Joost de Valk

    (@joostdevalk)

    Your CDN plugin is moving the XSL file to your CDN:

    http://maxcdn.pumpjunkies.com/wp-content/plugins/wordpress-seo/css/xml-sitemap-xsl.php

    the issue is, that an XSL file has to be on the exact same domain as an XML file for it to work, so you have to prevent your CDN plugin from doing this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Sitemap shows blank – Google seems to read’ is closed to new replies.