Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Sitemap Not Generating

  • Resolved vahost

    (@vahost)


    I’ve used the plug-in before with success on other WordPress blogs, but this time for the blog at http://www.sargearplus.com/blog the sitemap just isn’t generating for some unknown reason. The plugin settings say that I should be able to find the sitemap at http://www.sargearplus.com/blog/sitemap_index.xml, and that certainly makes sense, but no sitemap gets generated in the blog folder. When I try to visit that URL, I get a blank page.

    I checked the permissions for the blog folder, but they look good (755). I’ve also got the W3 Total Cache plugin, version 0.9.2.4 installed. I tried disabling it to see what would happen, but it still didn’t work. Turning W3 Total Cache back on and clearing the cache also did not fix the issue.

    I’m at a loss as to what to do next. Any ideas?

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Edward Seid

    (@brother7)

    Could the problem be with your host’s server setup? Because “View Source” for the xml page looks funky.

    vahost

    (@vahost)

    Hmm…I suppose it’s possible. It’s an e-commerce site, so anything is possible. However, the blog pages seems to work fine, and the e-commerce site works fine, so I’m not really sure where else to look.

    Any other ideas? I welcome further input.

    Plugin Author Joost de Valk

    (@joostdevalk)

    Well, you can welcome further input all day long, the problem isn’t going to get solved by our input 🙂

    Something is outputting all sorts of debug on your server, nothing we can do about that…

    vahost

    (@vahost)

    The sitemap page doesn’t seem to get written at all. When I check the files vis FTP, it’s not there.

    This is blog is on an ecommerce site that uses CGI. Is it possible that the CGI could be interfering with the sitemap being written?

    It seems like an unlikely possibility because I tried another WP plugin that just writes a sitemap, and the sitemap creates and updates just fine. That’s what makes this issue so inexplicable.

    Plugin Author Joost de Valk

    (@joostdevalk)

    There is not static file, never.

    inprojectcloud

    (@inprojectcloud)

    I have the same problem. When I click on view sitemap, it directs me to http://projectcloud.info/sitemap_index.xml where I get an error message. However, I do get a sitemap at http://projectcloud.info/sitemap.xml

    I am also using the plugin xml sitemap generator. Is there a conflict? Is it alright to remove xml sitemap generator? Does this plugin do the same thing?

    Plugin Author Joost de Valk

    (@joostdevalk)

    Please read the sticky in the top of this forum and then if needed open a new thread.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Sitemap Not Generating’ is closed to new replies.