Yoast SEO
[Plugin: WordPress SEO by Yoast] Sitemap not appearing in Google Webmaster Tools. (3 posts)

  1. Jon Poland
    Posted 4 years ago #

    I just switched from All In One to WordPress SEO by Yoast 2 days ago. Today I signed up for Google Webmaster Tools and Google is telling me that there is no sitemap for my site. Do I need to disable the XML Sitemap plugin that I was previously using?

    I was under the impression this great plugin was suppose to take care of the sitemap. Since is appears that it is not doing so, any suggestions on how to do this.

    Any help will be greatly appreciated.




  2. ecabral
    Posted 4 years ago #

    Hi Jon,

    Yoast SEO will generate XML sitemaps for you, so having another plugin to do the same is redundant.

    So, this is what I'd do:

    1. disable the XML Sitemap plugin
    2. in your WP dashboard, go to: SEO > XML Sitemaps
    3. enable 'XML sitemap functionality'
    4. click XML Sitemap
    5. copy the URL of your XML sitemap
    6. submit it in the Webmaster Tools

    Hope this helps!

  3. 411admin
    Posted 3 years ago #

    I see many posts about Webmaster not showing the automatic sitemaps from Yoast but I do not see any solutions. Is there one? Thank you for your help!
    Kate Mercer

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.