WordPress.org

Forums

WordPress SEO by Yoast
Settings could not be imported: Upload failed. (21 posts)

  1. talynndar
    Member
    Posted 3 years ago #

    using on my multisite- and set up one blog - its rocking! But it took me a long time to set up all the settings...

    now trying to import the settings to set up a new blog and getting this msg?

    Settings could not be imported: Upload failed.

    found a few old threads 3-4 months old and seems has been a challenge for a bit - but I dont see a solution -oh please say there is a fix?

    I am trying to upload settings.zip - not importing from previous seo plugin

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. talynndar
    Member
    Posted 3 years ago #

    bumping hoping for help here!

  3. SurvivalWoman
    Member
    Posted 3 years ago #

    I am having the same problem.

  4. esmconcepts
    Member
    Posted 3 years ago #

    You did not change the name for the default file did you. I just tried an upload and it worked fine moving the settings from one site to a different site.
    The default file to move is a zip file named "settings".

    Hope it helps.

  5. SurvivalWoman
    Member
    Posted 3 years ago #

    Nope no changes to the file name. I just tried again, though, and the upload succeeded BUT there were no changes to my settings.

    This is strange indeed.

  6. esmconcepts
    Member
    Posted 3 years ago #

    So, you did have entrys in the original plugin file from the original site? Yes.
    But these check marks do not make it to the NEW site? I'm I right?

  7. SurvivalWoman
    Member
    Posted 3 years ago #

    Yes, that is correct. I even looked at the export file and verified that the export was valid.

  8. esmconcepts
    Member
    Posted 3 years ago #

    Try un-zipping the "settings" file inside a folder on your computer.
    It will look like :

    [wpseo]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    usemetakeywords = "on"
    googleverify =
    yahooverify =
    msverify =
    version = "1.0.3"

    But it is all in one line kind of. Do you see the changes you made to certain entry's like; usemetakeywords = "on" <<<if you made this change to Use Meta Keywords with a check mark.

  9. esmconcepts
    Member
    Posted 3 years ago #

    I should have said, un-zip it and open it in a simple text editor like notepad.
    It's an .ini file and the lines run together. If you copy the open .ini file and then paste it in a Word editor the lines are normal and more readable.

  10. SurvivalWoman
    Member
    Posted 3 years ago #

    I will post it below. Thank you so much for your help!

    ; This is a settings export file for the WordPress SEO plugin by Yoast.com - http://yoast.com/wordpress/seo/

    [wpseo]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    usemetakeywords = "on"
    googleverify =
    yahooverify =
    msverify =
    version = "1.0.3"

    [wpseo_indexation]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    fb_pageid =
    fb_adminid =
    fb_appid =
    search = "on"
    noindexauthor = "on"
    noindexdate = "on"
    noindextag = "on"
    nofollowmeta = "on"
    nofollowcommentlinks = "on"
    replacemetawidget = "on"
    disableauthor = "on"

    [wpseo_permalinks]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    trailingslash = "on"
    redirectattachment = "on"
    force_transport = "default"
    cleanpermalink-extravars =

    [wpseo_titles]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    title-home = "Backdoor Survival Prepping Tips Tools and Preparedness Lifestyle"
    metadesc-home = "Survival tools and tips for creating a stylish, sustainable and frugal preparedness lifestyle using self-reliance and optimism.
    "
    metakey-home = "Survival blog, emergency food storage, self-reliant lifestyle, preparedness lifestyle, urban survival skills"
    title-post = "%%title%%"
    metadesc-post = "%%excerpt%%
    "
    metakey-post = "%%focuskw%%, %%tag%%"
    title-page = "%%title%% - %%sitename%%"
    metadesc-page = "%%excerpt%%
    "
    metakey-page = "%%focuskw%%, %%tag%%"
    title-attachment = "%%title%% - %%sitename%%"
    metadesc-attachment = "%%caption%%"
    metakey-attachment = "%%focuskw%%, %%tag%%"
    title-category = "%%term_title%% - %%sitename%%"
    metadesc-category = "%%category_description%%"
    metakey-category = "%%term_title%%"
    title-post_tag = "%%term_title%% - %%sitename%%"
    metadesc-post_tag = "%%tag_description%%"
    metakey-post_tag = "%%term_title%%"
    title-author = "%%name%% - %%sitename%%"
    metadesc-author = "Author Profile of %%name%% at %%sitename%%"
    metakey-author = "%%name%%, %%sitename%%"
    title-archive =
    metadesc-archive =
    title-search = "%%searchphrase%% - %%sitename%%"
    title-404 = "Page not found - %%sitename%%"

    [wpseo_rss]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    commentfeeds = "on"
    pingfeed = "on"
    rssbefore =
    rssafter = "%%POSTLINK%% was brought to you by %%BLOGLINK%%."

    [wpseo_internallinks]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    breadcrumbs-enable = "on"
    breadcrumbs-sep = "»"
    breadcrumbs-home = "Backdoor Survival"
    breadcrumbs-prefix = "Your are here:"
    breadcrumbs-archiveprefix = "Archives for:"
    breadcrumbs-searchprefix = "You searched for:"
    breadcrumbs-404crumb = "Page Not Found:"
    post_types-post-maintax = "category"
    breadcrumbs-boldlast = "on"

    [wpseo_xml]
    ignore_blog_public_warning =
    ignore_page_comments =
    ignore_permalink =
    ms_defaults_set =
    xml_include_images = "on"
    xml_ping_google = "on"
    xml_ping_bing = "on"
    xml_ping_yahoo = "on"
    xml_ping_ask = "on"
    taxonomies-post_tag-not_in_sitemap = "on"

  11. esmconcepts
    Member
    Posted 3 years ago #

    Hi,
    Are you using "WordPress multisite's" ?
    If not, and you do have Yoast SEO installed on the New site right?
    When you go into the plugin's admin page and at the bottom where it reads SEO/ Import & Export. Then under Import at the bottom. Click "Browse" to find the file you saved. Then click "Import Settings".
    I guess these are the steps you are taking?
    Right.
    Do you know your way around your webhost's cPanel?

    Just double checking that we are on the same page per say.

  12. esmconcepts
    Member
    Posted 3 years ago #

    I whent to your site: http://www.backdoorsurvival.com/ and it shows that <!-- / Yoast WordPress SEO plugin. -->
    is running.
    Is this the Old or the New site?

  13. SurvivalWoman
    Member
    Posted 3 years ago #

    Affirmative to all questions other than my host uses the Helm Control Panel rather than cPanel. (I am an old Cobol programmer - an antique - so yes, pretty technical in my basic understanding.)

    Backdoor Survival is the old site. The new site is http://www.strategic-living.net.

    Gaye

  14. esmconcepts
    Member
    Posted 3 years ago #

    On the new site when I "View Source" i do see the entry for Yoast SEO.
    Are you using a Cache plugin? If so, do a flush and empty all the caches files. Maybe it held up some how.?

    It might also be some security plugin stopping the upload?

    What Theme are you using? Could there be some other gremlins at work in your setup? Try and re-download then re-upload the setting file again.

    If all else fails, I hope someone else checks this post. I am not sure after this.

  15. esmconcepts
    Member
    Posted 3 years ago #

    Hi Gaye,
    As to the cpanel, I could not find a direct listing for the uploaded settings file on my sites cpanel. So don't know how to check it yet.

    COBOL! WHOA! Cool! 1 PERFORM UNTIL YOAST-WORDPRESS-SEO IS EQUAL TO "YES"
    Or if syntex error then GoSub.

    I like you sites. A lot of people will be in trouble if the power goes off. Then where is Google...

    Steve

  16. SurvivalWoman
    Member
    Posted 3 years ago #

    Okay, deleted the cache - no change. I use the Weaver theme on both sites. I performed a similar export and import of my theme settings when I first brought up Strategic Living.

    I checked the settings.ini on S-L by loading it in to a text file and clearly there was no change - just the default setting appear.

    You did give me an idea. I think I will delete the settings.ini file from my control panel and see if I can do an import instead of a rewrite. Perhaps that is the issue. Stay tuned.

  17. SurvivalWoman
    Member
    Posted 3 years ago #

    Well, that did not work.

    BTW, the settings.ini and settings.zip files can up found in your uploads directory - the same location as your media files.

    Gaye

  18. esmconcepts
    Member
    Posted 3 years ago #

    I think you are on the right path. I have done a new install on one of my sites and it worked as it should with no problems.

    I have to believe it is somthing simple. the reinstall might do it.

    I will be looking for the answer. Good luck.

  19. esmconcepts
    Member
    Posted 3 years ago #

    So you uploaded a settings file that DID have the info checked in it that you wanted? Did you re-zip it before you uploaded it from your computer? Or did you view it on your server?

    If you uploaded it through the backend with FileZilla or a FTP program, did it come up in the same format; .ini and not a .txt file?

    I will look in my Uploads dir and see if I can find any differences.
    Steve

  20. esmconcepts
    Member
    Posted 3 years ago #

    Also, if you FTP the file, did it ask you to OK the replacement file so it could overwrite it?

  21. esmconcepts
    Member
    Posted 3 years ago #

    Yes I see the file in Uploads. I use FireFTP inside FireFox and I checked inside my File Manager of cPanel.

    If your uploaded file looks OK, I would guess that Yoast SEO is not reading the file right or something to that effect.

    I know it's a hassel, but you might try deleating WordPress SEO and then reloading it. Then upload the settings.ini file before you make any changes to the new upload copy of Yoast WordPress SEO.

    Hope it helps.
    Steve

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic