Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] "robots" content="noindex,follow"

  • All my website pages, except “Page 1” – “Home Page” has
    <meta name="robots" content="noindex,follow"/>
    and Google doesent index them. I want ALL my subpages to be indexed, not only home page and posts.

    I tryed all chekboxes on “WordPress SEO” control panel, but it doesnt help.

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.1.4 - -->
    <link rel="canonical" href="" />
    <link rel="prev" href="" />
    <link rel="next" href="" />
    <meta name="robots" content="noindex,follow"/>
    <!-- / Yoast WordPress SEO plugin. -->

Viewing 8 replies - 1 through 8 (of 8 total)
  • I found it in readme.txt

    = 1.0.3 =

    * This release is dedicated to removing options and setting defaults instead. Specifically, the following settings are now defaults without options to change them:
    * Subpages of the homepage are now also noindex, follow. It just doesn’t make sense to index,follow those especially with the new rel=”prev” and rel=”next” changes.

    Its really stupid… i think about return back to “All in One seo”

    I don’t understand “Yoast’s” reasoning from the readme.txt you posted above. According to the official post here, rel=”prev” and rel=”next” are for articles or product categories with more than one page where you want to return the first page in the series instead of the second page of an article or product category. With blogs, page 2 to page last have totally different content on them and aren’t really part of a series so you wouldn’t return the first page instead of an inner page.

    The only valid reason I can see for implementing this is so that the SEs return individual posts instead of page 2 to page last but that doesn’t have to do with rel=”prev” and rel=”next”. There is no “noindex,follow” on the individual posts so SEs can crawl all the “/page/”‘s in the blog because of the “follow” attribute (or no “nofollow” actually since “follow” is default) and the SEs can index the individual posts even though page 2 – page last are noindexed. I think this is a good idea actually as long as there isn’t “noindex” on your individual posts which there shouldn’t be. At first I thought it was bad that page 2 to page last had “noindex” on them but, as long as individual posts are getting indexed, I think it’s a good idea.

    Do you see “noindex,follow” on individual posts or are they getting indexed?

    Posts are indexed, but http://xxxxx/page/2/ not.

    It looks a nosense….

    I’m also interested in this problem. Why Yoast decided for us to noindex something of our work, like the home subpages? Should leave the choice!

    There are several other things wrong in this plugin, for me:
    Often I have to update my permalinks because the category subpages give 404, GWebmaster tells that all categories subpages titles are duplicated two or three times and I don’t understand why, and periodically I have problems with sitemaps. There’s a lot of useless settings for pages and post (and even SEO check isn’t all that good, often wrong), but there are no general options for all the above things.
    Maybe I’ll go back to AIO, or even to my simple theme’s native SEO. All these complicated useless annoying things are too much.

    I started using WordPress SEO by Yoast. Google does not index any pages, post and categoryss. One single page is indexed by google the first page (home).
    I say that the show advanced (to all post) are looking like this:
    Meta Robots Index: Index
    Meta Robots Follow: follow
    Meta Robots Advanced: none
    Include in Sitemap: always include
    Sitemap Priority: automatic priorization
    Canonical URL:
    301 Redirect:

    PLEASE HELP, what it is wrong, google no index any pages, post and categoris.

    Has anybody at Yoast bothered to respond to this issue?

    Can this default be switched off so that all created pages can be followed?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] "robots" content="noindex,follow"’ is closed to new replies.