WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Plugin: WordPress SEO by Yoast] Posts Not Showing Up In Google

[Plugin: WordPress SEO by Yoast] Posts Not Showing Up In Google

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m experiencing this same issue, and have yet to find a solution. I’ve gone through all of Yoast SEO’s settings, and everything appears to be in order. Before switching over to WordPress SEO by Yoast, all posts were being picked up by Google, and they’d always come up as the first Google result when searching their post titles. After switching to Yoast, none of them show up in a search, even though the sitemap does include them, and I can see in GWT that Googlebot is having no trouble with the sitemap.

    I’m puzzled, frustrated, and so close to switching back to my old plugin instead of Yoast, which I’d really rather not do if there’s a way to resolve it.

    I switched to SEO Ultimate ’til this issue is resolved.

    Jay, if you wouldn’t mind, could you please report back here whether your posts start getting picked up again and are searchable by their titles?

    I’m going to give it another week, and if I can’t track down the root cause of it by then, I’ll be switching to an alternative plugin as well.

    i thought its only me experiencing this kind of issue, my rank as well didn’t show up since yesterday.

    I changed plugins and my post seem to show up so far.

    So your posts are showing up and searchable by title in Google now after switching plugins, Jay?

    Judging by the frequency of his posts here, it appears Joost doesn’t check these support forums all that often, so I’m figuring the likelihood of this and many of the other important issues getting looked into anytime soon is pretty slim.

    Yes, my posts created with SEO Ultimate so far are showing up. That plus using a sitemap plugin.

    Same issue here, looks like switching will be necessary.

    Which Sitemap plugin did you opt for? Previously, I was using the tried and true “Google XML Sitemaps”, but I’m up for a change if you recommend a different one.

    I’m going to make the switch away from Yoast today, and maybe revisit it a few months down the road when (hopefully) some of the major issues have been resolved.

    Your guys posts showing up in Google since switching?

    Had the same problem, switched today to other plugin. How long did it take till your posts titles showed up after switching to SEO Ultimate?

    Mine took a day or so, but I think one of the reasons mine weren’t showing up was due to having multiple plugins with the open graph tag. I had Simple Facebook Connect, SEO Ultimate (with the open graph module on), and SEO Facebook Comments. After I turned off the open graph module and deactivated the SEO Facebook comments, my posts started showing up again in Google.

    Did anyone get this problem resolved, please? I am having the same issue – Google is not picking up any terms including my website name even when in quotation marks. Is it solvable or do I switch? Any help appreciate. THanks

    Did anyone get this problem resolved, please? I am having the same issue – Google is not picking up any terms including my website name even when in quotation marks. Is it solvable or do I switch? Any help appreciate. Thanks

    I’m having the same problem. Some of it my doing though.
    After modifying the robot’s text to disallow only the /wp-contents/plugins folder…I’m going to see what happens.
    My site is not showing at all in google search and I don’t have any open graphs running.
    Right now I’ve stripped my plugins down and hopefully will see a change. I’ll give it a week and report back.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Posts Not Showing Up In Google’ is closed to new replies.
Skip to toolbar