Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] post_tag-sitemap.xml redirects to 404 page

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same issue here – all sitemap pages are working but the tags link results in 404 error. I have only about 20 tags, and so the file size cannot be the problem… My XML map address is this: …Did you manage to solve this? A reply would be valuable – thanks.

    Update: the Tag Sitemap now works but required a strange tweak. Perhaps anyone knows why and how this is important. So… All my tags have custom WordPress SEO settings – SEO title and SEO description. These are blank by default but can be added on Edit Tag page for each tag I have. Prior to testing my tag sitemap and learning that it wasn’t generating, I set up all my tags to have an SEO title and description. And I now determined that with these custom descriptions Yoast does NOT generate the tag sitemap, UNLESS each such tag has the “Include in sitemap?” option set to “Always Include”. By default, this setting is on “Auto Detect”, and this is the root of the situation: To get Yoast to generate the tag sitemap, you must either (a) leave the SEO title and description of your tags blank or (b) change the value of “Include in Sitemap?” field from “Auto Detect” to “Always Include”. In fact, if you had a bunch of tags and half of them had the custom title/description and the other half didn’t *and* all of them were set to Auto Detect, then the resulting tag sitemap would only include the tags whose title/description is blank. The natural question follows: why does Yoast WordPress SEO want to exclude tags with custom SEO title and/or description from the sitemap? Perhaps the values of these fields must conform to a certain standard or format? If that’s the case, what are the guidelines? (number of characters, prohibited characters, etc.)

    bpmstr….thanks for that post…I am having the same problem so I took your advice and changed all pages to “always include” unfortunately, there is still no sitemap generated, I am still getting the redirect error message. Do I have to do something else?

    The WordPress SEO Yoast has a BUG. It can sometimes fail to generate the sitemap unless you deactivate and then reactivate the plugin AND THEN follow a small procedure I will outline here. Do this: deactivate the plugin // reactivate it // go to XML Sitemaps section from the dashboard’s SEO side menu // uncheck the box at the top and click the blue SAVE button to DEactivate the XML sitemap function // then again check that box and save again to REactivate it // then – double verify that the correct options are selected for the sitemaps you want or don’t want included (tags/categories/pages, etc) and save again if you make any further changes. After that, click the grey XML sitemap button and see if that sitemap appears. If not, your problem is different from mine. If yes, awesome.

    Also, dude, make sure that you have at least one post tagged with at least one of your tags… If you have no posts with the tags for which you want the sitemap… then there is nothing to generate.

    Thanks for that….just one question before I do this……does deactivating mean I lose all my custom data? Do I then have to re-input the titles and descriptions again?

    WordPress SEO plugin is designed to not delete custom data. But WordPress is broad, complex, and sometimes unpredictable. And many plugins have (a) bugs and (b) conflicts with other another, which can cause them to do undescribable things. If you are not yet familiar with this notion, don’t touch anything and hire a professional. And if you are familiar, then stop worrying, back up your site often, and keep working.

    Thanks again for that……I did as you suggested but it still does not show me sitemap. Anyone got any other ideas?

    I have seen a LOT of unresolved posts on this topic, FYI, and I am yet to figure out what else may be wrong with this plugin. One possible approach is for you to communicate with Yoast directly through his website However, he will ONLY respond if your inquiry to him includes a request to review your site and to give you an evaluation for your SEO strategy. So, if you have ever considered looking into using a top-of-the-line SEO specialist, reach out to him and let him know you may want to hire him if he gives you an affordable proposition. While at it, let him know that his plugin isn’t working properly. He normally gets back to people who place inquiries like this within 2-3 days. Either way, good luck.

    Yes, I noticed the same thing! It is really frustrating as apart from that it seems to work fine and I am not sure how worried I should be about it? Will seo still be ok with all the titles and descriptions in place or do I really need the sitemap to bring it all together?
    I will try to contact him directly and report back here if I find anything out!

    A proper SEO strategy, generally, is to include either the categories or the tags in your sitemap, but not both. There are many schools of thought on that, but this strategy is well known. So, as long as your tags aren’t working, you may want to exclude them from your sitemap and include properly formatted categories only. However, if you decide to connect with Yoast, be sure to keep your tags sitemap turned on still, to give him a chance to see that they are not working when he looks at your site.

    Update…..I found an old thread where others had the same problem… appears that sitemaps just don’t work well for some sites but no one appears to know why! Solution is to uncheck the box enabling sitemaps and download the xml google sitemaps plug in. That works fine and in a matter of seconds!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] post_tag-sitemap.xml redirects to 404 page’ is closed to new replies.