WordPress.org

Forums

Yoast SEO
[Plugin: WordPress SEO by Yoast] Post & Page Title Problem (8 posts)

  1. Taim786
    Member
    Posted 2 years ago #

    Hi, I'm facing a little problem of titles of my posts and pages.
    I have updated my theme and after that Website Title "TaimoorSultan.Com" appears before every post title at the top of the browser.
    Please see this screenshot of browser, there is no space between post title and website name.
    http://i875.photobucket.com/albums/ab317/TAim_2010/1-21.png
    and when I deactivate this plugin, post titles are working as
    TaimoorSultan.Com >> Post Title
    On every post and pages. I just want include some space there in browser window so it don't look odd.
    My website address is http://taimoorsultan.com
    please check and guide my what to do..

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Snakeman
    Member
    Posted 2 years ago #

    same problem on my blog: http://www.nils-snake.de

  3. titanas
    Member
    Posted 2 years ago #

    Hey,

    Have you tried SEO > Titles & Metas > Force rewrite titles?

  4. dkiaulakis
    Member
    Posted 2 years ago #

    http://www.vivaldi.lt - duplicated title? why? Thanks.

  5. Taim786
    Member
    Posted 2 years ago #

    @titanas : Yeah thanks, it helps! But what do you think it will be good for SEO? just a thought because now Website title is not there at all.
    http://taimoorsultan.com/disable-seen-notifications-in-facebook-chatting/

  6. titanas
    Member
    Posted 2 years ago #

    @Taim786 a few thoughts: do you use UTF-8 as your blog encoding? Does your new theme supports wp_title properly? See here: http://codex.wordpress.org/Plugin_API/Filter_Reference/wp_title

    There is no single recipe for SEO. Usually what you see is post title + site name but that's up to you to decide what works best for you. You might want to use the full length of title and make it very descriptive rather than sparing a part of it for your site's name. Maybe it's more important for you to have your site's name next to your titles.

    Test what works best for you

  7. dkiaulakis
    Member
    Posted 2 years ago #

    Just removed title "thing" from plugin code, now looks like ok. Thanks anyway.

  8. Taim786
    Member
    Posted 2 years ago #

    I have got that problem solved :) with previous site. But when I installed it on new domain http://www.bloggerjin.com, it again starts displaying that space problem.
    Well, now I just want to make it clear for all users that just check the Force Rewrite Urls button at the Home tab and it will be alright. :)

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.