Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Post Info Missing in Facebook Shares

  • Resolved nickchill


    When I attempt to share my posts to Facebook, it comes up with a plain link. Facebook seems unable to find the title, description, or images for my posts. I’ve tried for my last 3 or 4 posts and it is still not working.

    At one point I manually inserted Facebook meta tags in my header, but have since removed those particular tags.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you turn on OpenGraph metadata?
    It’s found under SEO > Social.

    Yes, OpenGraph metadata has been on.

    It seems that Facebook has no problem retrieving the post info when I post using the WordPress shortlink. However, Facebook still is unable to pull the post info when posting the permalink.

    This is an issue, as the shortlink is not available to my readers when they go to share my posts.

    What social share plugin are you using?

    Remove http:// and the last / in your link and Facebook will read it properly.

    I think I’ve found the problem.
    I removed ALL of the meta description info from the “Title Settings” page, and it seems to be working fine. There must have been a conflict concerning the meta templates.

    @edward Seid – I’m using Sexybookmarks Shareaholic, but I don’t think it would matter which plugin I’m using. Even when I posted the permalink manually, it didn’t show info in Facebook. My readers only have access to the permalink, so they would have the same issue no matter how they shared.

    @daveteu – That would be a good workaround for the author to post on Facebook.

    Thanks for helping me troubleshoot, guys. I appreciate it.

    I usually don’t use meta description template as search engines sometimes penalize you for having similar or identical meta info for every page.

    If you are talking about just Facebook sharing, i don’t think it has got to do with wordpress but how Facebook handles the url.

    Can you try the following 1 step for me?

    Got to Settings -> Permalink -> Select custom structure and key in /%postname%

    Your permanlink will then appear as (Without the /)

    Then try using your social buttons again.

    @daveteu ~ When using the Meta Templates, you’re not supposed to use static information. You use tags (provided on the settings screen) which dynamically inserts information specific to each post/page. Doing this ensures you don’t have similar or identical meta info for every page.

    The Facebook sharing issue did have to do with WordPress. As I said in my previous post, I fixed the problem.

    I started by removing all of my meta template data. When that caused the sharing problem to disappear, I realized it was probably a conflict between the code snippet required for the SEO Title Settings to work <title><?php wp_title(''); ?></title> and the original Title header code. Turns out, at some point when updating my header.php file, I reintroduced the original Title code. I simply removed it, reentered my Meta Template data and I’m back in business.

    @daveteu OMG. Thank you so much for posting your solution about removing the trailing slash after the post name – I was killing myself trying to solve this problem and this worked perfectly. Best!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Post Info Missing in Facebook Shares’ is closed to new replies.