WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress SEO by Yoast] Plugin causes slow posting

[Plugin: WordPress SEO by Yoast] Plugin causes slow posting

Viewing 12 replies - 1 through 12 (of 12 total)
  • Bump? Stopped work on the plugin already?

    ditto. After installing 0.2.1 when I hit Publish for a post, it times out and goes to a 404 error page. However, the post does publish. Strange… When I deactivate it, everything is back to normal and I can publish without any problems again…

    I’m having the same problem.

    the only idea i have is that the plugin writes in the custom fields every time it publishes a post. having 13.000 articles takes about 3-4 minutes to do that. hope yoast fixes it soon.

    i’ve found a workaround: delete this function in admin/class-metabox.php

    function rebuild_sitemap( $post ) {
        global $wpseo_generate, $wpseo_echo;
        $wpseo_generate = true;
        $wpseo_echo = false;
        require_once WPSEO_PATH.'/sitemaps/xml-sitemap-class.php';
    }

    and start using another sitemap plugin.

    Same problem. Takes several seconds to publish the post.

    addictionreviews
    Member

    @addictionreviews

    I have encountered the same issue. I have 11,000 posts and it takes roughly 3 minutes to update or add anything. This is not a problem with the pages that I add.

    I have the added concern that when I deactivate the plug in my menu does not work (which are linked to post categories). I would like to try the fix that Vali posted above but I am a little concerned about doing that and would rather hear from Yoast about possible answers.

    You have an extraordinary plug in. Great work and I hope we can fix the issue soon.

    thanks

    try my fix, it will do until yoast comes with an official fix.

    addictionreviews
    Member

    @addictionreviews

    I tried the fix and ended up with errors. I am hoping the fix comes along soon or someone can help me. I have a serious amount of posts to do and update. The time it takes is killing me. Other than the speed though the product is outstanding!

    Please help!

    look for the rebuild_sitemap function in admin/class-metabox.php and delete the whole lines:

    // When permalink structure is changed, sitemap should be regenerated
    add_action(‘permalink_structure_changed’, array(&$this,’rebuild_sitemap’) );
    add_action(‘publish_post’, array(&$this,’rebuild_sitemap’) );

    addictionreviews
    Member

    @addictionreviews

    THANK YOU!! that worked!

    addictionreviews
    Member

    @addictionreviews

    I was dreading the posts that I was doing and very concerned about adding more. BIG HELP! Thanks again vali!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Plugin causes slow posting’ is closed to new replies.