Yoast SEO
[Plugin: WordPress SEO by Yoast] Page numbers not shown in category pages (9 posts)

  1. Praveen Kumar
    Posted 4 years ago #

    After install, when i go to any category page site.com/category/abc/page/4/

    the page numbers are not being displayed on the title.

    i checked and double checked my code and i could not find anything wrong.

    If i start using All in One SEO, the page numbers are showing up perfectly fine.

    Instead of

    Custom Category Title - Page 2
    Custom Category Title - Page 3
    Custom Category Title - Page 4
    It returns only
    Custom Category Title

    because of this Google is showing all the pages as having duplicate titles.

    Please help.

    ps: i left a message in the fb page, 2-3 emails and couple of replies to other related topics here but there has been absolutely no support from Yoast :(



  2. wouwi
    Posted 4 years ago #


    Same issue for me.

    I have custom SEO Titles for my categories, and the page numbers aren't showing at the end of the title.

    Thank you.

  3. lover-00
    Posted 4 years ago #

    I also have this problem - do not display the page numbers in the title
    Remove your poorly done plugin, I will continue to enjoy excellent All in One SEO.

  4. awhig
    Posted 4 years ago #

    I am having the same issue. SEO titles for my categories, where I put in a custom template (to show page #'s) never show up. Using version 1.0.3.


  5. alaing
    Posted 3 years ago #

    Same issue... please help us, this plugin is great !

  6. awhig
    Posted 3 years ago #

    Does anyone know if this was fixed in the latest release? I haven't tried it yet...don't want to mess with anything, unless it has.


  7. Praveen Kumar
    Posted 3 years ago #

    Yep, this has been fixed.

  8. awhig
    Posted 3 years ago #

    I tried changing the category title, and it still does not work for me.

    It works for me on the homepage template, but doing the same thing for the category template, all I see is the standard category name title.

    I first started off trying

    %%category%% Archives %%page%% - %%sitename%%

    but after this did not work, I simplified to


    as a test, and still did not see any changes.

    This is with Version 1.1.4 of the plugin, running on top of WP 3.3.1


  9. Praveen Kumar
    Posted 3 years ago #

    My apologies. I thought i was replying to SEO Ultimate.

    This issue is still not fixed in WordPress SEO. So i have moved to SEO Ultimate. The author did not respond to my emails or messages, so i decided to remove this plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic