Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] og:description not inserted

Viewing 15 replies - 1 through 15 (of 22 total)
  • Pat Garner

    (@wordpressorgpatgarnercom)

    P.S. – I deactivated all other plugins and my theme is twenty 11

    Same issue here.

    Thanks

    Same issue for me. Tried the development version, didn’t make any difference.

    Any news on this? Same issue here.

    Thanks

    I seem to be having the same issue as well…

    I am having the same issue at http://www.passagepillows.com. This seems like it may be an ongoing issue with the plugin.

    WordPress version: 3.5.1
    WordPress SEO version: 1.3.4.4

    I did this:

    Checked “Add OpenGraph meta data” on Yoast SEO –> Social.
    I entered Frontpage settings for the correct image which the plugin picks up and the description which the plugin does not pick up.
    I clicked Save Settings

    I went to https://developers.facebook.com/tools/debug/og/object?q=passagepillows.com

    I expected the plugin to do this:
    Produce a og:description tag.

    Instead it did this:
    No og:description tag. The Facebook debugger issued the following warning:

    The ‘og:description’ property should be explicitly provided, even if a value can be inferred from other tags

    My website URL is passagepillows.com
    Child theme of Twenty Twelve
    Still an issue after removing all other plugins.

    http://wordpress.org/extend/plugins/wordpress-seo/

    Same issue here. When I viewed my homepage source I saw this message in the comments…

    <!– This site is optimized with the Yoast WordPress SEO plugin v1.4.7 – http://yoast.com/wordpress/seo/ –>
    <!– Admin only notice: this page doesn’t show a meta description because it doesn’t have one, either write it for this page specifically or go into the SEO -> Titles menu and set up a template. –>

    Which is not very helpful. Is it saying we need to manually add it to the head? I went to the title menu and couldn’t see how or what to set up a template with.

    Going to the Yoast SEO Settings – > Title and Meta -> Home gives you the two options above.

    But they each just take you to either the default wordpress homepage or post editor.

    The og:description tag doesn’t seem to ever get explicitly defined as Facebook seems to want.

    OK found it.

    Follow the link in the Home tab through to your homepage (or blog page). Then find the Page specific Yeost SEO settings. Here use the general tab to set the description.

    Edit: You don’t even have to get there via the plugin settings. Individual page settings appear on your page editor, so you can update this directly while editing a page. Look for and click on ‘SEO – Check’. These settings will show up in different places (alongside page/post content, or below it) depending on your WordPress display settings.

    Ryan

    (@daobydesign)

    square_eyes isn’t wrong, if you set the meta description tag explicitly on a post-by-post basis, the og:description tag shows up. However, if you’re relying on the plugin to generate your meta descriptions using excerpts (or auto-generated excerpts), then it seems the og:description tag fails to be generated.

    Oddly, the Twitter (twitter:description) seems to load up just fine.

    Same problem here, i’ve a blog with thousands of posts without any custom Meta description.

    I would like to use the generated description based on the model of variables I choosed in the “Title and Meta” configuration setting of the plugin.

    I tried to add it on the header.php but I don’t know the name of the variable to use… Here is the code i tried :

    <meta property="og:description" content="<?php echo esc_attr( strip_tags( stripslashes( $metadesc ) ) ); ?>"/>
    or
    <meta property="og:description" content="<?php echo wpseo_get_value('metadesc'); ?>"/>

    Also, it could be good to display my og:desc only if the plugin doesn’t displays one (in case of the description explicitly entered in a the post).

    I don’t understand why the plugin works properly with twitter:description and not og:description but if anybody has an idea to help me to patch this in the header.php it would be great !
    Thanks.

    I just noticed the same problem, but it only started occurring for me after the last update – not 3 months or 10 months ago.

    I will explicitly add descriptions going forward, but I’m not in the mood to go back and write descriptions for my pre-existing posts.

    Would be nice if this could be narrowed down to what causes it, or if it’s a bug, get it fixed in the next update.

    I’m also experiencing this same issue. I’m not too familiar with PHP but I searched the plugin files and it looks as if there is not call to output the og_frontpage_image variable. That looks like the variable that’s collecting the Front Page Description on the WP SEO Social admin page, but I don’t see in anywhere in the other files to output that variable. It looks as if the file that outputs the Open Graph data is class-opengraph.php

    * Oops! I meant og_frontpage_desc as the variable

    I have the same issue… No “og:description” shows up even though I have explicitly entered it in the “Frontpage settings” of the Social settings of the plugin.

    WordPress SEO: Version 1.4.7
    WordPress: 3.5.1

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] og:description not inserted’ is closed to new replies.