Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Missing ALT tags

Viewing 13 replies - 1 through 13 (of 13 total)
  • me too! and I can’t figure it out

    I’m looking for an answer as well, any help appreciated

    I am getting this error when there are no images in the body section of the article. It seems like it might be a bug because there are no images for me to add an alt tag to

    When I check posts with images in the body section, I make sure to include the focus keywords in the alt tag and click update before running the SEO checking tool again – this has worked for me…

    Although this won’t be a problem for spiders if the alt text is actually in the HTML, it might matter how you are entering alt text to those images…I edit the image directly in the post. So, although it is an error for the Yoast SEO checker, I would disregard the error if the HTML has the alt tag – it could be an issue with how Yoast checks for the alt tag, which is different from parsing the actual published URL (which is what Google will see)

    I am getting the no alt in bing webmaster tools so I am still stumped

    I’ve been looking in to this issue for a while, as well.

    As best as I can tell, WordPress SEO by Yoast checks for images, within the post/page, being created, within WordPress, and not in the source of the entire, displayed page.

    I would like to review a specific post/page, any of you are having issues with. Please provide the URL to the post/page you are having issues with. Also provide a screen-shot of the error, being displayed on the “WordPress SEO by Yoast” Page Analysis tab and the permalink at the top of the page. I need these both to be visible, in the same screen-shot, to ensure the URL matches the Page Analysis.

    eaglejohn

    (@danielbenjamins)

    I think this is a bug. When you don’t have any images at all on your page, the Page Analysis is reporting this as well 🙂

    carlton@carltonmceachern.com

    (@carltoncarltonmceacherncom)

    I am getting this as well, even on pages with no images. Using WP 3.4.2 and NextGenGallery 1.9.6 – my site is http://carltonmceachern.com

    I am having the same issue. Has anyone reported a bug yet? This is very frustrating.

    eaglejohn

    (@danielbenjamins)

    As far as I know, Yoast is following the support threads for his plugin, so I hope he’s reading this one as well 🙂

    I too am getting this error across a number of sites where the only images are in the templates and I’m pretty sure that Yoast doesn’t check this. Even if it did, all my images have alt tags so assume this is a bug.

    Doesn’t stop you from getting a green light though 🙂

    Since my last post 2 months ago, I had been thinking I was OK since the code is correct. however recently i realized that the image title= is included in the code for each image twice and is the title of the post, NOT the image title I entered. Even worse, the alt text is also the title of the post rather than what I am entering in the Yoast alt field. Please help as this is a big problem since I wish to state “Image Representing” on all my image alt text and right now that is impossible with the title and alt text code being populated with the post title. I am using Yoast 1.3.4.1, WordPress 3.4.1, Shepard theme.

    Nathan

    (@yodaman5556)

    Having the same problem. Only just started now on the post that I’m writing at the moment. My site is http://brickextra.com. I’m one of those people that likes to have “green light” on their Yoast SEO plugin. At the moment it shows yellow. I put in alt tags for ALL of my images on the page and it still says (even after page reloads). If this is a bug, I hope Yoast fixes it soon. PLEASE!

    Nathan

    (@yodaman5556)

    Wait….I had one main centred picture above a 6 picture gallery and had a <div align=”center”></div> around them. When I went into the main picture settings there was no alignment, I selected “center” and then saved the draft. The Yoast SEO panel no longer says that there isn’t any alt tags. Maybe this could help some other people who had the same problem. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Missing ALT tags’ is closed to new replies.