Yoast SEO
[Plugin: WordPress SEO by Yoast] Meta Description persisting (3 posts)

  1. Andi76
    Posted 3 years ago #

    Hi there,

    I have the plugin installed and working correctly for all other components. The OG meta data is fine for everything other than description. Here is what Facebook debug tells me:

    Meta Tag <meta property="og:description" content="The new IKEA catalogue for 2013 has created a lot of buzz recently because it utilizes a form of augmented reality to enhance the browsing experience for the consumer." />

    But the correct description should be:

    <meta property="og:description" content="Calling all geeks, data nerds and content freaks. From writers to coders, journalists to visual enablers. Get your dose of interactive storytelling. Featuring creators that intersect content and technology. These are the stories that respond to you." />

    The weird thing is none of this is showing up in my header.php (presumably a theme issue) so I can't just swap it out.

    Any suggestions for why this description is persisting?

    Thank you.


  2. Andi76
    Posted 3 years ago #

    An update to the above to help debug. It appears to be pulling the latest post description.

    So I clearly have it set up wrong. How do I get my site meta description to remain consistent?

  3. Ali Valizadeh
    Posted 3 years ago #

    in my Persian Site , my old posts has Strange Description.
    Description show to question marks
    like this pic :
    question mark - desc
    my site has UTF-8 Coding and Keywords Are Currect but Yoast Description arnt valid.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic