WordPress.org

Forums

WordPress SEO by Yoast
Meta Description not Showing. Only WordPress SEO is installed. (8 posts)

  1. Blurazor
    Member
    Posted 3 years ago #

    Hi,

    I realized that the Meta Description of my web pages are not displayed. There is no other SEO plugins installed. I've checked the FAQ for the WordPress SEO plugin (see below) and my meta descriptions do contain the necessary keywords. Can anyone suggest what can I do to resolve this miss meta description issue?

    blockquote1. You're putting out more than one of them due to multiple plugins adding a description, for instance the WordBooker plugin adds a description too but has an option to disable it, other SEO plugins running might be another cause.
    2. You're not seeing your meta description show up in the search result pages. Google will not alway show your meta description, the likelihood of your meta description appearing in the search results increases incredibly when your meta description contains the sought for keyword though, which is why the focus keyword functionality checks for the appearance of the focus keyword in the description.blockquote

    Thanks a lot.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Please show me the URL of your site and the query you're trying.

  3. Blurazor
    Member
    Posted 3 years ago #

  4. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    It's showing the description here. But not your entire keyword phrase is in your meta description, so chance of showing it is low...

  5. didsy
    Member
    Posted 2 years ago #

    hi.
    I am having the same problem.
    i don't have any other seo plugin installed and I've used the focus keyword on the meta description, but google still uses the first lines of my post..

    the blog post is:

    Starbucks City Mugs | Aruba

    my intended meta description is:
    Starbucks City Mugs 2008 Icon Series for the country of Aruba. Learn a little about the country and the icon on the mug.

    my focus keyword is:
    starbucks city mugs

    is there something i'm doing wrong?

  6. mikeotgaar
    Member
    Posted 2 years ago #

    Hi all - If the meta description is in the page source - you're not doing anything wrong...
    Blame Google - Google doesn't always show the description you want it too

    @Blurazor - just had a look at the Google search you posted - The following snippet was dispalyed for Meta Description

    "Anger is a wild, fiery beast that can ruin lives and relationships. Learn how you can remain calm and composed in the face of chaos and discontentment."

    Matches the Meta description on the page ministryoftherapy[dot]com/services/anger-management/

  7. Sokos6
    Member
    Posted 2 years ago #

    I'm looking all over, and trying to figure out why our descriptions look terrible in google. For example, if I google Comic Booked Articles, many of the posts show up with all kinds of garbled stuff in them....Comment count, the link to the post, though all messed up with % in it and stuff.
    I've checked the search listings in wordpress, and they look fine. I've analyzed the URLs with different tools, and if i paste them into say, facebook, google + etc, the title and desc all look perfect. Am I missing something? Is something conflicting? I'm also getting a message in my permalinks settings area in wordpress. says htaccess not writeable, and it tells me to add this code....
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I don't know if this is causing the problem, but I'm VERY scared to make any htaccess changes....Also, there are MANY posts that we do have showing up in search just fine. Some just all wonky, and we need help.
    Thoughts????

  8. RoamFree
    Member
    Posted 2 years ago #

    Sokos6,

    I looked at the gatecrash-prerelease page's source code (right-click on the page to see source code), and in the Yoast section there are Description and Keyword sections. There is a Title near the top of the file -- I suspect that your theme is choosing to emit a Title up there.

    However, Google is choosing to emit an escaped URL (with a bunch of percentage symbols) as the description for that page. That escaped URL is in several places on the page, inside hidden comments. I think your theme is choosing to hide the comments, but Google is seeing them. Maybe Google will choose something else for the page's description, but it seems that at the moment Google is preferring those hidden comment strings.

    You might check if your theme has a way to not emit those comments at all, rather than just hiding them from view. If they're not generated, Googlebot won't see them.

    You might want to check if your theme has a configuration option to give priority to an SEO plugin, so Yoast's tool will emit all that it can. Sometimes a theme tries to emit its own SEO info.

    As for those htaccess changes, those look like the typical WordPress configuration. If that is not already in .htaccess, you can find the same rules in the WordPress documentation. Whether to try them depends upon whether your site is already behaving as you desire.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic