Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Meta description is allways NO

  • Hello,

    I write a post, publish it, and then I check the focus keyword results, allways I get that:

    Article Heading: Yes (1)
    Page title: Yes (1)
    Page URL: Yes (1)
    Content: Yes (2)
    Meta description: No

    Can someone explain me what I’m doing wrong?

    Also, in the Page Analysis I get this message:
    The keyword doesn’t appear in the first paragraph of the copy, make sure the topic is clear immediately.

    My focus keyword is in the first paragraph! So I can’t understand.

    Apreciate any help, have a nice time


Viewing 4 replies - 1 through 4 (of 4 total)
  • On the general tab of WordPress SEO in admin area you see this :
    1. snippet preview
    2. focus keyword
    3. seo title
    4. meta description
    type some text (short) description / excerpt in the textarea behind it. It will update to meta description: Yes

    Focus keyword in first paragraph :
    this does happen to me sometimes as well, but always when there is an image floating left or right before the first paragraph. I think it shouldn’t be that much of a problem though.

    Thanks ChillZZ!

    Chillz – I have the same problem.

    But I already did what you said, I go into the general tab of WordPress SEO and write the meta description, and it comes up in the display.

    But the description don’t come up on the Google results page. Instead, I get the “about me” description that I put on my site underneath my photograph.

    When I view source I get:

    [!– BEGIN HEAD –]
    [meta http-equiv=”content-type” content=”text/html; charset=UTF-8″ /]
    [meta name=”description” content=”” /]

    [meta property=”og:description” content=”Steps Google search bots…

    Shouldn’t the meta description I write be in between those empty speech marks? And what is the “og:description” bit? In the code, that always seems to be the first sentence of two from the page. But that description doesn’t even come up on the results page anyway.


    Greyblur : you’re not using WordPress SEO (Yoast), you’re using
    All in One SEO Pack on your website. This could be either a template problem, or a setting in the All in One SEO pack but I don’t know for shure, since I don’t use that one.

    You might try the forum/boards overhere :

    But yes meta description should be filled per page/post with a description you’ve typed for that perticular page, not a site default.

    og:description is the description opengraph ( Facebook ) uses to display when a page/post is shared.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Meta description is allways NO’ is closed to new replies.