Yoast SEO
[Plugin: WordPress SEO by Yoast] Meta Data not appearing properly to spiders (6 posts)

  1. jeremyers1
    Posted 5 years ago #

    Has anyone used any Spider Test tools online for their website? I have tried a few in the last day or two, and have noticed that none of the WordPress SEO meta data, such as description and keywords, gets read by the spiders.

    At first I thought it was my settings on my blog, but then I checked Yoast.com, and saw that the spiders were not even reading his meta data either.

    How can I fix this?

    Here is a tool I used:


    I checked my homepage and several of my posts and pages. I also checked yoast.com


  2. wpsuperhero
    Posted 5 years ago #

    good question i had infact done a check on my site and it didn't come up either, although one of my wp sites i have just put hard code in header.php. have you got a link url.

  3. jeremyers1
    Posted 5 years ago #

    My site is:

    Actually, yoast.com doesn't show up properly either, so it's not just my site.

    I tried this site that use the plugin:


    I used these three spider test tools:


  4. jeremyers1
    Posted 5 years ago #

    Ok, well,

    I let tentblogger know that his spider tool wasn't showing meta data from WordPress SEO, and it is now working. I don't know if he made a change to the tool or not...

    But the other two tools I show above still are not showing the meta description or meta keywords properly.



    I wish I knew whether or not the search engines saw this data properly.

  5. jeremyers1
    Posted 5 years ago #

    I found out why some spider tools see the meta data and others do not. It has to do with single or double quote marks. Some spider tools only check the double quote mark spider data. Yoast uses single quotation meta data, which is not wrong, but some of these spider test tools don't see it.

    I trust that actual Search Engines read both...

  6. jeremyers1
    Posted 5 years ago #

    Or...would it be possible to update your plugin so that the meta data is enclosed in double quote marks instead of single?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic