Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Link to page 2, page 3, etc not working

  • Resolved Tristan

    (@mrt209)


    Hi again,

    I’m having a problem with the links to page 2, 3, etc on my blog. When I click on the pagination on the front-page it redirects from /page/2/ to /18/ for some reason…

    Any idea how to make the links to the other pages working?

    Thanks! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Joost de Valk

    (@joostdevalk)

    Hmm that’s very weird, have you verified that this is not the case without my plugin enabled?

    Hey Joost,

    I was able to get it fixed by disabling “Redirect ugly URL’s to clean permalinks.” It works without a problem on my other sites, so I guess it has to do with the theme I’m using.

    Anyway, thanks for your help 🙂

    Joost! Same title shown in every paginated page in my theme.
    e.g. http://example.com >> WordPress Themes
    http://example.com/page/2/ >> WordPress Themes

    How can I setup like this
    http://example.com/page/2/ >> WordPress Themes – Page 2

    Thanks.

    I’m having the same problem again after install the jquery esaing plugin. I’ve disabled/deleted it, but I can’t get the links to page 2,3,4 etc work again 🙁

    Plugin Author Joost de Valk

    (@joostdevalk)

    I really need to know a bit more. Hasitha: that’s a different issue, please open a separate thread.

    It works again. Seems to be the easing plugin. After I installed/deleted it. I had to empty all the caches, re-save the permalinks setting in the SEO plugin, empty caches again, then re-save the WordPress permalink settings and update the settings in your plugin a final time.

    Not sure if all of these steps are necessary, but that’s how I recall it 😛

    Plugin Author Joost de Valk

    (@joostdevalk)

    It’s probably been fixed by 0.3.5 as well.

    Having the same problem again 🙁

    My links to the previous pages aren’t working, for example domain.com/page/2 redirects to domain.com/2/ causing a 404.

    Any idea how to fix this? I no longer have the easing plugin installed so that’s not the problem and I tried the steps I did last time without success.

    Thanks!

    The guys at Hostgator helped me get it fixed by installing the “Disable Canonical URL Redirection” plugin 🙂

    http://txfx.net/files/wordpress/disable-canonical-redirects.phps

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Link to page 2, page 3, etc not working’ is closed to new replies.