WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress SEO by Yoast] Is the Plugin adding an xhtml noindex meta tag to the RSS Feed?

[Plugin: WordPress SEO by Yoast] Is the Plugin adding an xhtml noindex meta tag to the RSS Feed?

  • I have the following line in my RSS Feed and I want to remove it:

    <xhtml:meta xmlns:xhtml="http://www.w3.org/1999/xhtml" name="robots" content="noindex" />

    I cannot figure out where it is coming from. I thought it might be a feedburner setting (under Publicize > NoIndex) but I have that option deactivated.

    Is this line being entered by some setting in WordPress SEO I cannot find?

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I found this in the changelog for version 1.0.3:

    RSS feeds are now always noindex, followed. No search engine should ever list an RSS feed as a result in the resultpages.

    Please return this as an option to let us choose what we want. It appears that sites like blogsearch.google.com may require an indexable RSS feed to list results.

    I manually removed two lines from the files to do this for me. I think I got the right ones. I am putting them here for my own sake, just so I can remember where I found them and what I did… and in case anyone else wants to remove this also.

    I removed the following two lines from wordpress-seo/frontend/class-frontend.php

    add_action('rss_head', array(&$this, 'noindex_feed') );
    add_action('rss2_head', array(&$this, 'noindex_feed') );

    @jeremyers1

    As you said to remove

    <xhtml:meta xmlns:xhtml="http://www.w3.org/1999/xhtml" name="robots" content="noindex" />

    from feeds we need to remove these two lines:

    add_action('rss_head', array(&$this, 'noindex_feed') );
    add_action('rss2_head', array(&$this, 'noindex_feed') );

    But even after doing this nothing happened it still shows

    jeremyers1
    Member

    @jeremyers1

    You will need to publish a new blog post to get the lines removed. Publish a new post, and then check your feed again. The nofollow should be gone then.

    thanks….now I can see that there is no “noindex” commend in feeds

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Is the Plugin adding an xhtml noindex meta tag to the RSS Feed?’ is closed to new replies.