Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Images Missing in Sitemap

  • Resolved Rajesh Namase

    (@namaserajesh)


    WordPress Version: 3.4.1
    WordPress SEO version: 1.2.6

    I expected the plugin to do this: Add images in XML sitemap. Everything is fine in 1.2.5 but when I updated the plugin it shows 0 images in front of every post URL in sitemap.

    Instead it did this: Showing zero images in XML sitemap. Not adding images in sitemap.

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Rajesh Namase

    (@namaserajesh)

    Just checked that everyone having same problem, checked sitemap on yoast.com same problem.

    UfukArt

    (@ufukart)

    Same problem.

    akdwivedi

    (@akdwivedi)

    Same issue with me.

    Rajesh Namase

    (@namaserajesh)

    Updated to 1.2.7 still same problem.

    spherical

    (@spherical)

    :\ Same here, running WP v3.4.1.

    spherical

    (@spherical)

    Found it! A missing “r”.

    Line 549 in inc/class-sitemaps.php:

    if ( !isset( $img['sc'] ) || empty( $img['src'] ) )

    should be:

    if ( !isset( $img['src'] ) || empty( $img['src'] ) )

    Image counts are back.

    Keith Aldrich

    (@keith-aldrich)

    Same issues. Tried adding the missing “r”…still not working. Reverting back to 1.2.5 solved the problem.

    dp-wurzel

    (@dp-wurzel)

    @spherical
    Yes it works…. thanks!!!

    MfG dp-wurzel

    Sundance

    (@alyahfoufi)

    same here , adding r did not solve the problem,
    how did you revert to 1.2.5 ? and do you lose all seo configurations ?

    Sundance

    (@alyahfoufi)

    never mind , I downgraded and problem solved

    pepe

    (@pputzer)

    The missing “r” and resaving the sitemap settings fixed the problem for me (3.4.1)

    Rajesh Namase

    (@namaserajesh)

    Thanks spherical, problem is solved.

    JWSchaeffer

    (@jwschaeffer)

    Awesome– thanks spherical.

    The line to be edited for me was on 544. The same missing “r” just a few lines below.

    Problems resolved 🙂

    I added the missing “r”, deactivated and reactivated all plugins, resaved xml settings but nothing worked (3.4.1)
    I tried uploading the class-sitemaps.php from the previous plugin version and it partially solves the problem, although my portfolio sitemap (theme specific) still appears without images.
    Any suggestions please?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Images Missing in Sitemap’ is closed to new replies.