WordPress.org

Forums

WordPress SEO by Yoast
[resolved] Google does not read Yoast SEO title tags (5 posts)

  1. Mike Imken
    Member
    Posted 3 years ago #

    I'm using WordPress 3.2.1 and Genesis 1.7.1, then installed the Yoast SEO plugin.

    I used the "Titles" section of the plugin, which is supposed to be able to create a homepage title and meta description, but after several days found my site nowhere on Google when it should have been at least within top 5 pages, as it's a niche site.

    Then when I pulled the site up directly I saw that Google was ignoring the plugin settings entirely and instead using the generic WordPress site title and pulling its own description.

    Needless to say, this isn't a functional plugin if it can't create a Google friendly title setting for the homepage or other pages.

    Maybe it's incompatible with Genesis, but regardless I'm back to using the native Genesis SEO. It's a shame because I like the plugin's other features.

    Just putting this out there in case someone else has similar issues or if it's a bug to be fixed.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Mike Imken
    Member
    Posted 3 years ago #

    Update: Joost is helping me with the issue. I'll post the results. Great support for a free plug-in I have to say.

  3. michaelborger
    Member
    Posted 3 years ago #

    PLEASE let me know what you and Yoast find out. I'm a Genesis user as well (AgentPress Two 2.0.1 child theme) and having issues with titles and descriptions as well -- AND, possibly Google ranking issues as well per your post.

    Thanks.
    http://bigrockinvestments.com

  4. beathoven79
    Member
    Posted 3 years ago #

    Hello, I have similar problem.
    I'm runnig WordPress 3.3.2 with Yoast SEO.

    Google seems to ignore meta description and keywords added by plugin.
    When I preview source code, all plugin generated tags (decription and keywords) are in place.

    Somehow Googlebot prefers to use original wordpress mainpage description and content of pages as their description instead of Yoast's.

    Just guessing - maybe if it is template issue (im using Core v1.2 with few modifications), or conflict with other plugins?

    Thanks,
    beathoven79

  5. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    These should be fixed... If not, please open a new thread and describe your issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic