Support » Fixing WordPress » [Plugin: WordPress SEO by Yoast] focus keyword problem

  • Hello Everyone,
    I’m having an issue with the Focus Keyword on WordPress SEO plugin – sometimes works, sometimes doesnt.

    I’m admin and I can see that it works (it gets green if I have the kw in the right place) but then a user with only author rights sees it all RED.

    This is a big problem for me, I’m trying to make a point and instead look like a newbie without an answer…

    Did anyone encounter this problem? How can I fix it?

    Thank you,

Viewing 5 replies - 1 through 5 (of 5 total)
  • I had this exact issue just this morning, except that even as an admin for one post it worked but for the next post it didn’t. It didn’t find the keywords in the title, in the content all lights stayed red.

    I’m wondering exactly what is the ‘focus keyword’?

    I found this issue also, I fixed it by retyping the titles with same words… Then everything turns green…
    Seems a glitch, but funky one



    I ran into this as well. For me the issue was a period in the keyword.

    Take for example the keyword: “St. Peters Church”

    The Focus Keyword field doesn’t seem to like the period. I haven’t tested this with any other characters or punctuation.

    Has anyone else had this problem?



    I have had this quite often myself. What seems to help it along is saving it in draft, re-adjusting your titles and text a little, and trying again.

    Sadly it’s not the fix-all, but seems to help at times. I still have a very difficult time trying to get them all green–like it hates me!

    Yoast SEO doesn’t seem to work live as you work, so saving is one way to work around it.

    Might not be helpful to all, but in hopes for some.

    I had the same problem when using a period in my keywords. Removing the period fixed the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] focus keyword problem’ is closed to new replies.