Support » Plugins and Hacks » [Plugin: WordPress SEO by Yoast] FATAL ERROR on Dashboard from this Plugin.

[Plugin: WordPress SEO by Yoast] FATAL ERROR on Dashboard from this Plugin.

  • WordPress version: 3.4
    WordPress SEO version: 1.2.1

    I did this:
    (It works on my main website)

    I expected the plugin to do this:

    Instead it did this:
    Under “Incoming Links”, “Other WordPress News”, and “WordPress Blog”
    Fatal error: Call to undefined function wpseo_title_test() in /home/akshay/public_html/wp-content/plugins/wordpress-seo/inc/wpseo-functions.php on line 402

    This is only on my multisite website not on my main website.

    I’m not Updating to 1.2.2 because it’s not compatible with 3.4(according to Yoast) and 2 people said it didn’t work.

    Someone please help!


Viewing 15 replies - 16 through 30 (of 36 total)
  • I am sorry but didn’t get the details of ‘how’ he fixed it just that those two were the problem files. I wish I had asked him but was so shocked that he was able and willing to fix it I just said thanks. Sorry. If I can get back to him, I may ask but only got a first name, Irving. Not much help I know but he did it in 30 seconds so it must not have been too hard.

    Actually I was getting help on ‘chat’ and not on the phone if that helps.

    Can you download your /wp-content/plugins/wp-table-reloaded/ folder, zip it up and make the zip file downloadable somewhere? I’ll do a compare in WinMerge and be able to see what he changed in there.


    I chat with them online too.

    The fix is quite easy.

    AJAX calls will nor load wp-seo-non-ajax-functions.php thus wp seo does not provide wpseo_title_test() used by wpseo-functions.php

    Simple diff would be
    – 402 wpseo_title_test();
    + 402 defined(‘DOING_AJAX’) and DOING_AJAX or wpseo_title_test();

    Bug does persist in 1.2.2 and trunk.

    I had the same problem, although the error only showed on one of the sites in my multisite installation. The other sites weren’t affected. The error first occurred when trying to add a menu item, which thus failed.

    After upgrading to the dev version, adding a menu item worked, but the error is replaced by another one, saying “Warning: Invalid argument supplied for foreach() in /home/username/domains/domainname.com/public_html/wp-content/plugins/wordpress-seo/inc/wpseo-functions.php on line 407”.

    When trying to change to the default 2011 theme, I get the following error:

    Warning: Invalid argument supplied for foreach() in /home/startnepal/domains/startnepal.com/public_html/wp-content/plugins/wordpress-seo/inc/wpseo-functions.php on line 407

    Warning: Cannot modify header information – headers already sent by (output started at /home/username/domains/domainname.com/public_html/wp-content/plugins/wordpress-seo/inc/wpseo-functions.php:407) in /home/username/domains/domainname.com/public_html/wp-includes/pluggable.php on line 866″

    With the dev-version you got something else.

    The upgrade mechanism is looking for a “wpseo” option, that does not seem to exist. Missing check for $opt == false or is_array($opt).
    Since it is just a cleanup task to migrate older plugin versions that should be enough.


    FWIW, I’m also getting the following error on another multisite install (2 sites) and that one does not have WP-Table Reloaded installed as was mentionned above. The error at the top of blog 2’s admin pages:

    Warning: Invalid argument supplied for foreach() in /path/to/wp-content/plugins/wordpress-seo/inc/wpseo-functions.php on line 407

    That’s with version 1.2.3 with WP 3.4

    M. Penz post right before mine gave me a clue to look int the database and I found something interesting. The “wpseo” option does exist on this 2 site ms network but the value for the blog 2 version is weird. The blog 1 version of the wpseo option contains this serialized array:


    But the same option in the blog 2 options table contains this:


    … which is a simple text string and not a serialized array which the code probably expects. I tried to copy the value from the blog 1 options table to the blog 2 options table and the error went away for me. Not sure if this can have other adverse effects on how WordPress SEO works but at least the error is gone for me for now.

    But this definitely seems like a bug in 1.2.2 and 1.2.3 and one which probably has nothing to do with a conflict with other plugins.

    form when I updated my wordpress I’m not able to insert new image….but my error is

    “Cheatinโ€™ uh?”
    I’m going crazy also because one moderator don’t trust me…I did it all that he told me but doesn’t works…please help me ๐Ÿ™ ๐Ÿ™ ๐Ÿ™

    I am also getting the error where my dashboard disappears when the Yoast SEO plugin is installed. The problem began when the most recent update was installed.

    Just switched to All In One SEO Pack. Solved all my problems.

    Also waiting for a fix, I also have -12345 after my google listing, if you type in 12345 in google you can also see how many other people have this error which I guess is from the same error and plugin.

    The “-1234″5 issue is easy to fix. Just go to the Title & Meta settings of the plugin and check the “Title template” for the home page, post types, taxonomies and others. If it shows “%%sitename%% – %%sitedesc%% – 12345” just remove the last part.

    @ yakti-ruud Great, thanks for pointing that out

    Yes, I was about to point out that you can fix the -12345. I don’t know why home titles reset though. And this error still needs to be fixed. There is an error on every page and it is annoying. Whenever you save it also gives and error and doesn’t load. Please fix soon.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] FATAL ERROR on Dashboard from this Plugin.’ is closed to new replies.