WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Resolved] [Plugin: WordPress SEO by Yoast] Fatal Error

[Resolved] [Plugin: WordPress SEO by Yoast] Fatal Error

  • am getting this error on my multisite not on main domain but on sub networks when i try to access them i have to disabled multisite wordpress seo and only activate on main site only

    Fatal error: Cannot use string offset as an array in /home/content/d/r/i/serverhome/html/websitefolder/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 614

    http://wordpress.org/extend/plugins/wordpress-seo/

    [No bumping, thank you.]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Joost de Valk

    @joostdevalk

    Which version of the SEO plugin are you using that you’re encountering this error on? I need to know to be able to track down that line.

    am using Version 1.1.9, when i active the wpseo through multinetwork it works on main site, however on sub network sites i throws that error at me. i have to disable it through multi-site and activate it under main site plugins menu instead, and even using that method to activate through its own plugin method on sub site don’t work still get the same error.

    Plugin Author Joost de Valk

    @joostdevalk

    Could you copy what’s there on line 614 of that file?

    Do you have static sitemap_index.xml files?

    i have this at line 614: $options[‘blocking_files’][] = $file;

    and yes i do have an sitemap_index.xml file in my root folder

    Hello Joost,

    I also have a fatal error since the last plugin update :
    “Parse error: syntax error, unexpected ‘{‘ in /homez.51/thetaiko/www/wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 510”.

    The line 510 is :

    if ( isset( $options[‘metakey-‘.$post->post_type] ) && ( !$metakey || empty( $metakey ) ) {

    My website : http://www.thetaikonauts.org/

    Can you please help…?
    Thanks a lot !

    Plugin Author Joost de Valk

    @joostdevalk

    ahuggup86: remove that file. The file is not generated statically and that file block the sitemap generation.

    thetaikonauts: You’re running 1.1.8 I assume, upgrade to 1.1.9. And in the future, please open a new thread instead of hijacking someone else’s.

    so remove the file class-sitemaps.php

    I apologize, ahuggup86 and Joost, I didn’t mean to hijack the thread.
    I did the new update after disabling the plugin. When re-abled, it works fine again.
    Thanks !

    if i remove that file or rename it i get an error on my website that same file is not found.

    Warning: require(/home/content/d/r/i/myserverhome/html/mywebsitefolder/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php) [function.require]: failed to open stream: No such file or directory in /home/content/d/r/i/myserverfolder/html/mywebsitefolder/wp-content/plugins/wordpress-seo/wp-seo.php on line 55

    Fatal error: require() [function.require]: Failed opening required ‘/home/content/d/r/i/serverfolder/html/websitefolder/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/d/r/i/serverfolder/html/websitefolder/wp-content/plugins/wordpress-seo/wp-seo.php on line 55

    Plugin Author Joost de Valk

    @joostdevalk

    No, do not remove class-sitemaps.php, remove sitemap_index.xml.

    oh oka, so after removing that should i activate wp seo on sub blogs an test if i get same issue, what else should be done

    Plugin Author Joost de Valk

    @joostdevalk

    Yes, make sure the class-sitemaps file is back though.

    it worked joost wow, thanks very much and i can see all my settings from primary blog as well, thanks very much, i also activated it at network level and it works perfect.

    Plugin Author Joost de Valk

    @joostdevalk

    Nice.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] [Plugin: WordPress SEO by Yoast] Fatal Error’ is closed to new replies.
Skip to toolbar