WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Facebook OpenGraph Image Problem (20 posts)

  1. Munif Tanjim
    Member
    Posted 2 years ago #

    WordPress version: 3.3.2
    WordPress SEO version: 1.1.7

    The default image for facebook open graph is not working. I have configured the following settings from SOCIAL submenu of the Plugin.

    Frontpage settings
    Image URL:
    Description:
    Default settings
    Image URL:

    But when I check the result form Facebook Object Debugger(http://developers.facebook.com/tools/debug), It says that,

    "Inferred Property: The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags."

    It was working fine on the previous version of the plugin. But the new version has a bug on this feature.

    Please solve it.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Are you sure you have the settings correctly on the SEO -> Social page? Can you share a screenshot of that and the URL of your site?

  3. Munif Tanjim
    Member
    Posted 2 years ago #

    Sorry for late reply.

    My image link : http://lh5.googleusercontent.com/-ggAXKjMSCXc/T6o7lND-JLI/AAAAAAAAAVE/nhX5tjDn2gs/s200/seha-fb-og.png

    Check the result : http://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fs3h4.com

    Settings screenshot : http://i.imgur.com/pjBAr.png

    version 1.1.6 was working fine. I have also checked latest 1.1.9 version. It has the same problem.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Found the issue indeed, I think I've fixed it in the development version now, could you try?

  5. Munif Tanjim
    Member
    Posted 2 years ago #

    Thanks very much. Now I am checking. I will comment here after checking it.

  6. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, I'm awaiting anxiously ;)

  7. Munif Tanjim
    Member
    Posted 2 years ago #

    Would you please let me know which files you have revised? It will be easier for me to replace those few files. Thanks.

  8. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    No, just replace the whole thing please.

  9. Munif Tanjim
    Member
    Posted 2 years ago #

    ok.

  10. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Let me know how it turns out :)

  11. Munif Tanjim
    Member
    Posted 2 years ago #

    Nothing changed. Same problem.

  12. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    What are you using? the default image or the frontpage image?

  13. Munif Tanjim
    Member
    Posted 2 years ago #

    I have set both of them.

  14. Munif Tanjim
    Member
    Posted 2 years ago #

    The same setting I have used with version 1.1.6. It was working fine.

  15. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    I'm sorry but I can't do anything with that info :)

    I'd like to know your precise settings for homepage and default image... You've got a normal blog homepage right?

  16. Munif Tanjim
    Member
    Posted 2 years ago #

    I have set a static page as homepage.

    And set this image as default image : http://lh5.googleusercontent.com/-ggAXKjMSCXc/T6o7lND-JLI/AAAAAAAAAVE/nhX5tjDn2gs/s200/seha-fb-og.png

  17. hackzach
    Member
    Posted 2 years ago #

    Is this happening on single blog posts for you? I had a problem getting any page other than the homepage to show an image property, so I looked at the Opengraph class and it looks like if a single post has no attachments etc it will not add an image. I added the default image code from class-opengraph.php right after the if(is_singluar()) test for the image function and it works for me now.

    After seeing your website, it may still be relevant as I think pages are technically singular. Even though if you have a page set as the homepage it should have added the frontpage image.

  18. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm hackzach, you might have just found the issue. Could you test the development version for me?

    You can download the development version from here, or you can download it directly here.

  19. Munif Tanjim
    Member
    Posted 2 years ago #

    Now, it's running exactly fine. Thanks for the Great Plugin.

    Soon, I will translate the plugin into my language, Bengali.

    Problem solved. Topic Closed.

  20. Munif Tanjim
    Member
    Posted 2 years ago #

    How to join translate.yoast.com ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.