Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Errors in sitemap

  • Resolved tizz

    (@tizz)


    From the last upgrade (1.2.3) some problems that I had seems fixed, but now I got other errors in xml sitemap, reported by GW.
    Yesterday was 446 and I was hoping it would solve itself, but instead it’s getting worse.
    There’s 1.055 total errors in sitemap_index.xml, as follows:

    URL is not valid, correct it and resubmit, Main tag: image, tag: loc.

    446 are in post-sitemap.xml and 609 errors in page-sitemap.xml

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 1 through 15 (of 71 total)
  • No one else has got these errors? Sitemaps are visible in browser.
    I’ve disabled all plugins and activated 2011 theme, nothing change.
    Anyway Google Webmaster needs time to detect changes, so I dont know what to do.
    Some tips would be appreciated

    I also have same issue.
    I bet its something in relation to nextgen gallery and sitemap.

    <image:loc></image:loc> in sitemap is empty now, instead of having a link to images (issue appears only to nextgen gallery images, when default wordpress images are ok)

    Here is a screenshot

    You’re oh so right. Now, I have no idea on what to do, do you?
    The last two SEO Yoast plugin upgrades has given so many problems, it’s about 2-3 days that I’m not doing nothing else but trying to solve them.
    It’s quite stressful.

    WordPress version: 3.4
    WordPress SEO version: 1.2.3

    I have problems with sitemaps too: the category sitemap seems to have disappeared (reported by Google Webmaster Tools here too…).

    As a quick temporary solution i replaced plugin files from backup (17 of june) – before last upgrade was done, at least no errors i see in sitemaps now.
    And will wait for updated version with fixed bugs. Maybe will create a test blog to upgrade monitor when issues are fixed then will upgrade main blog. Thats the only thing comes to my mind as a solution

    (back to Version 1.2.2)

    Brad Dalton

    (@wordpresssites)

    Me too. I’ll try removing Next Gen and Using the native gallery. Not sure i can link native gallery thumbnails to url’s

    Plugin Author Joost de Valk

    (@joostdevalk)

    Hey everyone, could you please try the development version? I’ve been working hard to fix these issues.

    You can download the development version from here, or you can download it directly here.

    Would love to know if that fixes things. You might have to go to SEO -> XML Sitemaps and re-save the settings, let me know if that’s the case.

    Thanks Joost,
    Have activated the development version, re-saved sitemaps page settings and resubmitted sitemaps. The same error is still showing on posts and pages sitemaps. The only sitemap not showing error is the category sitemap which has been fine from the beginning.
    Look forward to further developments.
    Jo

    Brad Dalton

    (@wordpresssites)

    I’ve removed the Next Gen gallery and replaced it with the WordPress native gallery retaining all functions.

    Also written a post on how to do this without losing and functions.

    Brad Dalton

    (@wordpresssites)

    Sitemap: /post-sitemap.xml
    Parent tag: image
    Tag: loc
    412
    Jun 23, 2012
    Sitemap: http://wpsites.net/post-sitemap.xml
    Parent tag: image
    Tag: loc
    417
    Jun 23, 2012
    Sitemap: /post-sitemap.xml
    Parent tag: image
    Tag: loc
    422
    Jun 23, 2012

    Down to 82 errors after removing Next Gen plugins

    I can’t remove Nextgen, I have a lot of galleries handled by that plugin and it’s an important part of my website, native gallery isn’t the same.
    If I had to choose between the two, I would rather give up WordPress SEO plugin and re-install AIO, but I really hope I never have to choose.
    Possibly, I can keep the Yoast plugin and disable only the xml map and use Google XML Sitemap plugin by Arnee for this.
    Also I won’t downgrade SEO plugin, because the previous version gave me some others problems now fixed, so I should go back two versions.
    It could be useful to know what’s the file in question, the one that generates the image tag, so we can take only that one from a previous version. I haven’t tried dev version, because Jo says it doesn’t fix that error… or it’s only a matter of time?

    Brad Dalton

    (@wordpresssites)

    You can easily setup the native gallery to do exactly the same as Next Gen

    ComBron

    (@combron)

    Dear Joost,

    I don’t have the guts to upload the development version, since I don’t have as much knowledge as you do.

    I have problems with the xml-sitemaps as well. As soon as I switch to php 5.3 (by adding some lines to the .htaccess) the sitemaps disappear, get switched off.

    I’ll wait till the new version is released. Just wanted to let you know I appreciate your magnificent labour and your great skills.

    Edo

    Freelander

    (@freelander)

    @joost, I’ve tested the development version and I can also confirm that the problem still persist. Thank you very much for a great plugin and for your hard work!

Viewing 15 replies - 1 through 15 (of 71 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Errors in sitemap’ is closed to new replies.