WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Plugin: WordPress SEO by Yoast] delete meta description

[Plugin: WordPress SEO by Yoast] delete meta description

  • Hi
    Love your work first of all!
    The plugin wants me to dele the theme original meta description, from the plugin panel i get this message”
    Your theme contains a meta description, which blocks WordPress SEO from working properly, please delete the following line, or press fix it:
    <meta name=”description” content='<?php echo get_bloginfo( ‘description’, ‘display’ ) ?>’ />

    i tried to delete this both by using the delete button function and manual delete the line in the header.php
    But still i get the same message…what should ido and is there some special order to solve….
    hoping for help…
    cheers
    eoolk

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 16 through 30 (of 47 total)
  • To all,
    This may be an option.
    See if your theme has a built-in SEO option. In other words, did the theme author include SEO in the theme. If so, try disabling it. Then try to refresh your browser for the WPSEO dashboard and see if the problem still exists.

    after I did the update v1.2.8.2 my title is no longer shown. Any suggestion anyone?

    Stefan’s solution worked for me – clicked “Fix”, scrolled down and clicked “Save,” and the red error message went away. (This was after I upgraded to v1.2.8.2)

    About the title the problem is Resolved ppls, i just did remove the code of in my head.php `<title><?php if ( is_category() ) {

    echo 'Category Archive for "'; single_cat_title(); echo '" | '; bloginfo( 'name' );
    	} elseif ( is_tag() ) {
    		echo 'Tag Archive for "'; single_tag_title(); echo '" | '; bloginfo( 'name' );
    	} elseif ( is_archive() ) {
    		wp_title(''); echo ' Archive | '; bloginfo( 'name' );
    	} elseif ( is_search() ) {
    		echo 'Search for "'.wp_specialchars($s).'" | '; bloginfo( 'name' );
    	} elseif ( is_home() ) {
    		bloginfo( 'name' ); echo ' | '; bloginfo( 'description' );
    	}  elseif ( is_404() ) {
    		echo 'Error 404 Not Found | '; bloginfo( 'name' );
    	} elseif ( is_single() ) {
    		wp_title('');
    	} else {
    		echo wp_title( ' | ', false, right ); bloginfo( 'name' );
    	} ?></title>

    to simply </title><?php wp_title();?></title>

    About the <meta name=”description” content='<?php echo get_bloginfo( ‘description’, ‘display’ ) ?>’ /> error, just delete the code in ur head.php go to panel and click “Fix”, scrolled down and clicked “Save,” and the red error message went away.
    all is working now.
    thx ppls,
    and sorry about my english. ^_-

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum’s parser.]

    @ Stefan. Your solution is fine, thanks. How come I didn’t thought before about this? 🙂 Usually clickin’ save in the Yoast plugin fixes all :))
    Clicked on fix it, then on save and the error and warning messages disappeared. Then updated to 1.2.8.2 and everything seems OK.
    Now I can also see “tracking”, with the error it was disappeared at all.

    @ Richard. Theme built-in SEO should be disabled in any case if you use a SEO plugin.

    @richard, i guess my fix wasn’t a rubbish after all 😉

    @stefan, good job mate it did work for me as well, people just make sure you click save

    I’m also having this problem.
    My site:
    http://www.disastercake.com

    My Error:

    Your theme contains a meta description, which blocks WordPress SEO from working properly, please delete the following line, or press fix it:
    <meta name="description" content="<?php if ($my_meta['seo'] != '') { echo $my_meta['seo']; } else { the_excerpt_rss(); } ?>" />

    Pressing fix it then save does not make the error go away. I can also not find this code anywhere in my files to manually delete it.

    Same problem here after upgrading WP SEO.
    I pressed for both lines the Fix-it button in the plugin’s dashboard, pressed Save Settings: red warning message was still there.
    [My theme: Magazine Premium by Bavotasan. Built-in SEO turned off.]
    Only after I manually deleted the 2 lines from the header.php,
    the warning was gone.

    I brought this up in the themes forum; theme developer’s reaction:
    “The line will not go away in the PHP file [after you turn the built-in SEO option off] because it needs to be there in case you want to turn it back on. Whatever warning the WP SEO plugin is giving you can be ignored because once the SEO options in MP is turned off that meta description line will not appear on the front end.”

    Whole topic: http://themes.bavotasan.com/support/discussion/2128/wp-seo-upgrade-causes-problems-in-magazine-premium/#Item_1

    I’m not sure what to do. Think I’ll put the 2 lines back in header.php. I really hope that Joost de Valk will comment on this.
    Thx.
    My site http://charlesdevre.nl

    I just followed the instruction above to click the SAVE button, and it worked for me — I noticed a note that the cache had been cleared, which makes me think: if you have any caching going on, that might be why you’re still seeing the error after deleting the offending line from header.php. Makes sense? (Or it could have just been a coincidence…)

    I also experienced this issue with the meta description reporting as being incorrect. I Clicked the fix it button, nothing happen. I physically edited the header.php and removed it. Still nothing.

    I then returned to the plugin, hit fix it AND THEN clicked save settings.

    It fixed it!!!

    If Joost is still watching this thread I just wanted to let you know that I love your plugin and I have tracking turned on and it works great. I’ve been using it on many of our sites and it still ranks supreme in the SEO plugins for wordpress.

    To the naysayers out there. Please keep in mind that Joost is very well respected in the WordPress community and SEO community. Just because someone doesn’t reply immediately doesn’t mean you are being ignored or that their plugin sucks.

    Opensource software comes with some expectations and as such you have to agree to accept them when you install them. Let’s all keep in perspective the amount of personal time plugin developers devote to the creation and on going UNPAID support of the plugin.

    Thanks again for an amazing plugin that I am thankful has been in my arsenal.

    Stefan’s fix worked for me.

    In the dashboard for the plugin, I clicked on ‘save settings’ and the warning vanished.

    None off the above worked for me. I can’t seem to clear the error message. I am using a new theme, got the error message, deleted the code from my header.php file and it worked. However, the theme was recently updated to include meta data and now getting rid the error message has been impossible. I really like this plugin, but I wish the bug would get fixed soon.

    I was doing some testing this morning with the WP Supercache plugin and I checked the box “Coarse file locking” in the Advance Settings page. This caused the Yoast SEO plugin to display this error message : <meta name="description" content="<?php bloginfo('description'); ?>" /> `.
    So I unchecked that box, went back to the Yoast SEO plugin and I clicked on the red “Fix” button. The error disappeared and I saved the setting.
    So that worked for me. I think I saw on W3 Total cache a check box that will affect the Yoast SEO plugin as well (something about Javascript ?.
    If you have already tried to fix the problem by clicking on the red “Fix” button then it might not work but try renaming or deleting the .bak file that was created when your first clicked on the red “fix” button – something like: header.php.wpseobak – in your theme directory, and then go back to the yoast SEO plugin and try to fix it again using the red “Fix” button.
    Hope this will help someone.

Viewing 15 replies - 16 through 30 (of 47 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] delete meta description’ is closed to new replies.
Skip to toolbar