Yoast SEO
[Plugin: WordPress SEO by Yoast] Confused - 3 xml files & google sees none (5 posts)

  1. swarmcatcher
    Posted 4 years ago #

    I am using Yoast WordPress SEO amd i understood that it would create an xml sitemaop and let google know it was there, but in google sitemaps there is no indication of it.
    It asks for an address but I have 3
    Sitemap Last Modified
    http://www.goenviro.co.uk/post-sitemap.xml 2012-04-16 22:13
    http://www.goenviro.co.uk/page-sitemap.xml 2012-04-16 22:25
    http://www.goenviro.co.uk/category-sitemap.xml 2012-04-16 22:13

    Should I be using a different plugin like "better wordpress google xml" which generates just the one and submits it for me.
    Or am I completly mis understanding or missing something?
    All help appreciated, as i am very new to this


  2. Edward Seid
    Posted 4 years ago #

    Your sitemap is located at http://www.goenviro.co.uk/sitemap_index.xml

    Go into Google Webmaster tools and submit that URL as your sitemap. That's the index file which points to the rest of your sitemap files. You only need to submit the one index file, not all the others.

  3. swarmcatcher
    Posted 4 years ago #

    Thanks for that, as I say I'm clueless but learning, and can't find a reference to that link anywhere, so a BIG thank you

  4. Paul Kaiser
    Posted 4 years ago #

    The reference to that link is on the WordPress SEO setup page for Sitemaps. It looks like a button.

    However, it still doesn't work for me, either. Google Webmaster Tools tells me that the different sitemap files generated cannot be accessed because they are blocked by robots.txt.

    That is a "WordPress virtual" robots.txt, since I don't have a real one.

    So I disabled the sitemap in Yoast WordPress SEO and turned on Google XML Sitemaps, set it up, etc. I submitted the generated sitemap, and Google Webmaster Tools then told me, basically, it could not access any of the URL's in the sitemap due to the robots.txt file.

    Just FYI, In Dashboard > Settings > Privacy, I do not have the site blocking searching engines. I will say that I *did* have it blocking them until about 6 hours ago when I was ready to launch.

    Perhaps it takes longer for robots.txt to be visited again by Google?

    Anyway, it doesn't seem to be a WordPress SEO Plugin problem -- rather a robots.txt issue.

    Good luck,

  5. swarmcatcher
    Posted 4 years ago #

    I think you are right that it takes some time for the robots.txt to be revisited - though I'm not the expert by any means

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic