Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Causing any url typed in ending with .xml to give 200 status (shou

  • I’ve been using the xml sitemap option on the plugin, but decided to make my categories ‘noindex’ as they just display duplicated content. So I ticked categories under ‘Exclude taxonomies’ option in the sitemap settings as i didn’t want noindexed pages in my sitemap.

    This seemed fine until I had a warning in webmaster tools that I had a duplicated meta title and this lead me to find that the old category-sitemap.xml was still giving a 200 status. Not only this but its was indexed in Google, duplicated my home page meta title, description and added my page title as a h2 tag. Its also added the home page canonical, but doesn’t seem to have any effect, its still indexed and coming up as duplicated meta in web master tools

    Following this i have dropped out of the serps for over 100 page 1 keyword rankings, which is a bit of a kick in the teeth to say the least. ( this may or may not have been caused by this issus however, Google update and all that)

    When you view the page it looks as if its my 404 page, but giving a 200 status. Also you can type any old url ending with .xml it gives the same page, not a 404 as it should.

    Here is a screen shot

    I thought it might be an issues with W3 Total Cache, but have tried it with all plugins off and it gives the same results, the pages only give a correct 404 response one i turn off the Yoast SEO plugin.

    Be weary when turning off previously used xml sitemaps, you could get the same error.

    Now I’m just trying to decide the best course of action to remove this page from the serps, as i do like the other working features of the plugin. I can’t remove it in web master tools as it doesn’t give a 404 status and I’m not sure it adding it to the robots.txt file will be enough.

  • The topic ‘[Plugin: WordPress SEO by Yoast] Causing any url typed in ending with .xml to give 200 status (shou’ is closed to new replies.