WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Resolved] [Plugin: WordPress SEO by Yoast] Bug when allowing search engines after first forbidding them(?)

[Resolved] [Plugin: WordPress SEO by Yoast] Bug when allowing search engines after first forbidding them(?)

  • Hi there,

    I use the Yoast-SEO-Plugin for some months now and I think it’s a great plugin.

    What I noticed is, that when you first disable blog-indexing in your WordPress privacy settings and then later reactivate it, with the Yoast-Plugin installed, there’s no “index,follow” tags!

    I searched in the code and found the following line in class-frontend.php:

    $robotsstr = preg_replace( '/^index,follow,?/', '', $robotsstr );

    After commenting it out, everything usually works fine and as expected. I dont really know why this line is there. Maybe the plugin checks if indexing is disabled and then adds this line and later forgets to remove it (after indexing is enabled)?

    Greets.

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 2 replies - 1 through 2 (of 2 total)
  • @lupor
    It looks like your concern is the “index,follow” is not being added to meta robots e.g.
    <meta name=”robots” content=”index,follow”/>
    The plugin doesn’t add this as it’s not required.
    Google (and the other important search engines) will index and follow any page WITHOUT “noindex,nofollow” so having “index,follow” is entirely optional.
    Your blog will be indexed and links followed without that markup (I’ve got hundreds of pages in Google index – none use the “index,follow” robots meta markup)
    Hope this sets your mind at ease

    Ahh thx, you’re right, my fault. Just thought that in previous projects, there was a “index,follow” – but it seems there wasn’t.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: WordPress SEO by Yoast] Bug when allowing search engines after first forbidding them(?)’ is closed to new replies.
Skip to toolbar