Support » Plugin: Yoast SEO » [Plugin: WordPress SEO by Yoast] Appending of numbers to title

Viewing 15 replies - 1 through 15 (of 43 total)
  • sturtos

    (@sturtos)

    I’m having the same problem. 12345 in site title. I deactivated, installed pro and reactivated and it’s still there.

    The Titles & Metas page is blank… any ideas?

    Plugin Author Joost de Valk

    (@joostdevalk)

    Hmm that’s a result of the titles check functionality…. Let me see what could be causing that.

    gravymatt

    (@gravymatt)

    Yeah, we have an index/homepage that came with the wordpress template that is not a post or page and it pulls in the 12345 on the page title, because it is not set by WordPress SEO by Yoast

    sturtos

    (@sturtos)

    Mine is also an odd homepage in that it is built using Genesis widgets, it isn’t a static page…

    RichardWantsToKnow

    (@richardwantstoknow)

    A day, and still no answer.
    It doesn’t make any difference what theme you are using.

    RichardWantsToKnow

    (@richardwantstoknow)

    If you deactivate WPSEO the two spaces and five digit don’t show up any longer (not to say they still aren’t in some file in the site somewhere…); and they are replaced by a space and vertical bar, which is obviously still in some file somewhere on the site.

    sturtos

    (@sturtos)

    Richard – I also noticed that deactivating the plug-in corrects the title. Unfortunately I’ve spent so much time configuring the plug-in I’d really like to be able to use it! If this isn’t resolved soon though I’m going to have to go with another solution…. 🙁

    RichardWantsToKnow

    (@richardwantstoknow)

    @graymatt,
    Why do you say it is not set by WP SEO???
    I disagree. You turn off WP SEO and it appears to go away, and leaving a remnant.
    In my opinion, it appears that WPSEO is what is causing it.

    RichardWantsToKnow

    (@richardwantstoknow)

    @sturtos,
    I moved over to another this afternoon. I’ve pretty much wasted the better part of a day that was already set aside for another site project. It’s bad enough working six days/wk for 10 hours each, but having to do a seventh is not what I had in mind. It would be different if it was a one-off occurrence, but it appears there are a number of us with the same problem. I don’t understand why a solution hasn’t been offered yet. And I am wondering if bits will be left behind in the files.

    sturtos

    (@sturtos)

    Richard – I think that gravymatt meant that it wasn’t set by the plug-in because our homepages aren’t actual pages or posts; it must be pulling from somewhere else in the program.

    I don’t have any kind of home document that I can edit the title in, I think that’s what gravymatt is dealing with too. Is your homepage an actual page?

    I’ll probably end up using the built in Genesis SEO since I built my site on that platform.

    RichardWantsToKnow

    (@richardwantstoknow)

    @sturtos,
    Yes, we use a post on one and a page on another. (If you are running WordPress, I’m not sure how you can run anything but either. You can set a page to be static.)
    It’s my understanding that when you set up a WordPress site, you enter the site name into the Settings/General page, which in turn loads that information along with the other bits into one of the database tables; and that the browser tab gets it’s information from the database. I can only guess that the WP SEO either creates a new datum for the database and re-directs to it; or, edits the existing information the author entered into the Settings.
    I could be wrong but that’s my understanding.

    John Levandowski

    (@jlevandowski)

    @yoast

    The issue is in the file wpseo-non-ajax-functions.php line number 290

    $options[‘title-home’] = ‘%%sitename%% – %%sitedesc%% – 12345’;

    RichardWantsToKnow

    (@richardwantstoknow)

    @yoast,
    Okay…. Would you care to tell us what the problem is? And the appropriate way to fix it? Is what you quoted in the line beginning with “$options”, is that what it is or what we should change it to???
    Obviously, we didn’t write the code so I really don’t want to compound the problem by making some assumptions and taking the wrong action.
    So, could you elaborate please?

    RichardWantsToKnow

    (@richardwantstoknow)

    I’m spitballing here, and probably making incorrect assumptions, but I would guess the two dashes and the digits come from a lack of a site description. However if there was a site description, I see no reason the dashes and the digits wouldn’t still show up; which, is still unacceptable. Not to mention, when we turn off the Yoast product, the “- – 12345″ is replaced by ” |”, which is also unacceptable. And you haven’t explained where that comes from…..
    So, do we just delete one line of code? (Which seems a rather strange coding practice; and more like a band-aid over a larger issue. Just wondering…..)

    RichardWantsToKnow

    (@richardwantstoknow)

    Found that file under wordpress-seo/inc; but no trace of the line of code you quoted in the file. The date of the file is 1/12/2012; and there are a total of 189 lines of code in the file according to cPanel Code Editor.

    Can you confirm the directory you found it in and the version/date of the file??

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘[Plugin: WordPress SEO by Yoast] Appending of numbers to title’ is closed to new replies.