WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress SEO by Yoast] Adding opengraph meta data makes header W3C Invalid

[Resolved] [Plugin: WordPress SEO by Yoast] Adding opengraph meta data makes header W3C Invalid

  • adskiremote
    Member

    @adskiremote

    When I check the Add OpenGraph Meta Data it automatically adds an entry which W3C is saying is invalid markup.

    <meta property='og:locale' content='en_US'/>

    My site is XHTML 1.0 Transitional and the others og:description, og:title are ok.

    Anybody has a solution to this other than unchecking the box and manually adding OpenGraph meta data?

    Adam

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 6 replies - 1 through 6 (of 6 total)
  • I do have also a problem with this meta-tag:

    In the yoast-part in the header:
    <meta property=”og:locale” content=”nl” />

    Facebook debug tool error:
    “Object at URL ‘http://www.dailybits.be/item/behind-the-scenes-your-bags-airport-journey-door-delta/’ of type ‘article’ is invalid because the given value ‘nl’ for property ‘og:locale:locale’ could not be parsed as type ‘enum’.”

    It should be “nl_BE” or “nl_NL” not?

    I modified your code and hardcoded my “nl_NL” value where your are writing the local-tage and now everything is working, so could you bugfix this in your next version? thx!

    indigoclothing
    Member

    @indigoclothing

    How do I change the locale value as our source states:

    <meta property='og:locale' content='en_us'/>

    but we are not in the US?

    Plugin Author Joost de Valk
    Member

    @joostdevalk

    indigoclothing: please make a new thread next time as your issue is not related. The plugin takes your locale from the wp-config file.

    Cenay
    Participant

    @cenay

    Okay, back to the issue at hand… the code still doesn’t validate.

    <meta property=’og:locale’ content=’en_US’/> is the line that is reported with errors. I have a client that is demanding all errors be resolved, but without hacking the plugin, I can’t.

    Can you suggest something?

    Justin Gilpin
    Member

    @justin-gilpin

    They said this issue is resolved? It’s clearly not! Infact you guys have had plenty of time to work out the open graph bug. Why not?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: WordPress SEO by Yoast] Adding opengraph meta data makes header W3C Invalid’ is closed to new replies.