Support » Plugins and Hacks » [Resolved] [Plugin: WordPress SEO by Yoast] breaks admin

[Resolved] [Plugin: WordPress SEO by Yoast] breaks admin

Viewing 15 replies - 1 through 15 (of 71 total)
  • Christine Rondeau


    Volunteer Forum Moderator

    Do you have other plugins installed? I use WordPress SEO on a lot of sites and haven’t see that.

    I would recommend deactivating all other plugins, activate WP SEO and see what happens. If it looks good, then activate all of the other plugins one by one. I’m just guessing here, but I think that there might be a conflict between plugins.

    If the other plugins are more important than the SEO one, maybe try the all in one SEO plugin?

    Thanks Christine.

    Yes I have more plugins, I will test when I have the time to deactivate everything, which is not fun and time consuming. For the time I will stick to 1.2.7 which works fine and with no problems at all.

    I’m seeing the same problem with the new version.

    WordPress version: 3.4.1 (multisite)
    WordPress SEO version:

    I did this: updated the plugin – network activated the plugin

    I expected the plugin to do this: work as usual

    Instead it did this: broke admin access for all newly created sites on the network – we’re also seeing some other weirdness that may be related wpconfig.php. Now getting errors with W3 Total Cache…

    this line disappeared FROM wp-config.php???
    define(‘WP_CACHE’, true); // Added by W3 Total Cache

    I network deactivated and the newly created sites’ dashboards are functioning normally.

    I disagree with deactivating all of our other plugins – this release is what created the conflict…

    Christine Rondeau


    Volunteer Forum Moderator

    Thanks for your input. Looking at the plugin home page, I see that others are having issues too. Hopefully Yoast gets back to you soon. He’s usually very good and should come out with a fix.



    Forum Moderator

    It’s not possible to set the meta tag for the home page. When I go to Title&Metatag -> Home the plugin redirect me to General tab.

    I have the same problem with (Admin panel fails, with blanks)

    I need help, please.



    Forum Moderator

    My line 441 of wordpress-seo/admin/class-admin.php in new version is:

    of update_option( 'wpseo', $options );

    But I have the same problem: admin panel of plugin with some blanks.



    In addition to a nonfunctional admin panel (w 1.28), I have had problems with my sitemaps since the release of 1.28 – intermittently losing all sitemaps and / or losing the category / tags sitemeps (404) having implemented the 1.28 option fix, upgrading to the development version 1.28.1 and now currently back on 1.27. currently I have a functional sitemap_index.xml, posts and pages but the category / tags sitemaps throw 404’s.

    I experienced this same thing on a site this morning.

    This was my error:
    Fatal error: Call to undefined function update_options() in /data/s10/dom2262/httpdocs/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    I experience also some issues with 1.28.1

    – settingspages plugin without text labels
    – all my settings were removed
    – keep giving me the newversion-popup to confirm that I want tracking.

    yes, have the same problem since the newest plugin update:

    WordPress version: 3.4.1 (multisite)
    WordPress SEO version:

    When activating WordPress Seo then I get

    Fatal error: Call to undefined function update_options() in /home/www/web246/html/sites/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    Deactivating all other plugins is not a solution, the error remains.

    Any solutions?

    ok, found the solution here http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-wordpress-seo-caused-my-site-to-display-just-white?replies=37 and works fine now:

    Go to the plugin’s folder
    and removed the “s” from update_options() on line 441

    line 441 must be so:

    update_option( 'wpseo', $options );

    now it works fine for me.

Viewing 15 replies - 1 through 15 (of 71 total)
  • The topic ‘[Resolved] [Plugin: WordPress SEO by Yoast] breaks admin’ is closed to new replies.