Support » Plugin: WordPress Reusables » [Plugin: WordPress Reusables] Parse error when activating plugin

Viewing 10 replies - 1 through 10 (of 10 total)
  • I activated version 3.0.7 on WP 3.0.1 with no warnings or issues. Perhaps a corrupted download?

    I’m having the same problem. I notice we are both on OSX…
    I tried installing through the wordpress panel, then manually downloading and installing that way. Neither worked for me.
    I’ve tried erasing and reinstalling several times.

    Specs:

    OSX.6,
    64 bit,
    MYSQL 5.1.47
    PHP Version 5.3.2
    Apache 2

    Update: I wanted to add that I’m using wordpress 3.0.1 and version 3.0.8 of resuables.

    Hello.
    
    The problem is with tag '<?' of php. In php5 you have setup don't use this tag and use only '<?php' tag.
    
    You need to change '<?' by '<?php' and '<?=' by '<php echo()' in the files reusables.php and class.wp-plugins.php

    Yo need to replace too in the another files:
    page-edit.php, meta-reusables.php, page-about.php, page-add.php, page-insert-meta.php, page-insert-post.php, page-preview.php, tinymce.reus.js.php,

    Interesting. Is this because my version of php is too low, or because this was made for php 4?

    Hmm. After doing this and then activating the plugin, it caused my wysiwyg editor to stop showing previews (it only showed html in both tabs). It looks like this plugin just isn’t in the cards for me 🙁

    snooze

    (@snooze)

    Here it is Almost Thanksgiving 2010. It appears that in version 3.10 all PHP tags have been fixed yet I still get:

    Parse error: syntax error, unexpected $end in C:\Program Files\BitNami WordPress Stack\apps\wordpress\htdocs\wp-content\plugins\reusables\reusables.php on line 821

    #821 is the last line.

    Does it have a problem in local stack installations?

    Plugin Author ooeygui

    (@ooeygui)

    Snooze — Try removing the last line of reusables.php. (ie: Get rid of the ?> all together). This almost sounds like the file is somehow being altered with what I’m thinking is a space or some other invalid character after the closing PHP tag.

    Let me know if this works so I can update the plugin.

    Techism — It might be that you’re using PHP5.3, try switching to 5.2 if you can.

    Version 3.10 still has some php tag problems. To get it working with PHP 5.3, one needs to change <? to <?php in the following files:

    class.wp-plugins.php
    line 425
    line 452 (you can also delete the space)

    reusables.php
    line 658

    Not sure about Techsim and snooze’s problems, but that fixed mine.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WordPress Reusables] Parse error when activating plugin’ is closed to new replies.